LD2410 BLE not being re-discovered

Hi,

I’ve added a bluetooth proxy and a HLK-LD2410’s to my setup to experiment with presence detection. The initial setup worked like a charm, the proxy and the LD2410 were automagically added and it seemed to be working flawlessly :slight_smile:

However after a while the presence detection sensor reported unavailable even though the proxy and the LD2410 were immediately adjacent to one another, so couldn’t see that it was a range thing.

I decided to delete the integration from the UI and re-add the device. I unplugged the 2410, restarted Home Assistant but alas it was no auto-discovered. So I tried to manually add the integration, but was presented with a " LD2410 BLE - No unconfigured devices found." message.

I’m unable to locate any existing devices or entities associated with the LD2410 BLE integration and unable to add a new. Its like the previous instantiation has been tidied up and is preventing it being added again, but I can’t find any evidence of this.

Can anyone offer any advice?

TIA

1 Like

UPDATE - The simplest solution to this problem I come up is was just create a new BT proxy and disabling the old one. The LD2410’s were automatically discovered and operating as expected. Possibly not the most elegant solution, but it worked.

Restart proxy not work ?

Unplugging / plugging in the proxy was the first thing I tried, but it did not solve the issue.

LD2410 BLE
No devices found on the network
any configuration yaml for this?

Thanks for your response, but the issue was resolved as per my post on the 26th.

There is no YAML for the LD2410 BLE, its natively supported by by home assistant and is auto discovered and configured via Bluetooth connection, in my instance via BT Proxy

I too have this problem. My house has multiple BLE proxies and coverage is not an issue with plenty of slots available. I have been experimenting with the LD2410’s in both ESPHOME Uart via ESP32 and standalone BLE modes.

When I restart HA, the LD2410 BLE’s often become permanentky unavailable. If I delete them and restart HA again they all just get rediscovered and work.

Im struggling to see that this is a BLE issue, wondering if anyone can shed some light on this rather than blaming the chinesium sensor or the BLE environment.

guidance appreciated thanks.