LED Controller HF-LPB100 - Auto Detect works but can´t control Strip

Hi all!
I just started using Home-Assistant and I love it so far!
With nearly unlimited possibilitys an Idea popped up if it would be possible to control a specific LED-Strip with it.

Poorly I do not have the Informations about the manufacturer or the specific model…
I´ve tried to link it anyways and did a little researching and found out that the controler uses a HF-LPB100 Chip.

With this Information i came a little further and was able to auto detect the Controler via Home Assistant with following entry in the configuration.yaml:

  - platform: flux_led
    automatic_add: true

After restart I can see that a device was found with the correct IP Address but it is greyed out and I´m not able to Control it.

I know the Informations are extremly rare with missing Informations about manufacturer etc. but hopefully someone could give further input on what to try next or how to receive more needed informations or even how to solve my problem.

If it helps as an indicator… The Controler was casting an own Wifi before I linked it to my iot network - SSID was something like “EasyLighting…”

I would really appreciate your Help!

Thanks in advance and have a great day!

There are some updates coming to the flux_led integration but they aren’t integrated into the core of HA yet.

They can be installed as a custom component for the time being. You would need to download the files from the PR and put them in your custom_components folder under a sub-folder called flux_led and the system will pick up the custom / new code in place of the built-in integration.

This should provide you a working controller.

The latest version of this is at https://github.com/home-assistant/core/pull/44333

Thanks for your answer!
I´ve tried your suggested steps but still same behavior.

Just to be sure I´ve done this right (like mentoined I´m new to Home Assistant) and the new version from flux_led was loaded correct…

Create a sub folder in the same directory as the configuration.yaml called flux_led and copy the files from Git in there without any other sub dir like the core right?
Means a path like “…/custom_components/flux_led/”


That should be all you need to do (and yes you have the path correct).

Do you now have the integration showing under the Configuration -> Integrations page?

This update moves it to a UI configured integration, so if you don’t see it there it isn’t loaded.

On Integrations Page I don´t see a flux led like icon actually.
Seems it is not loaded.

Is there any other way to trigger the load of custom components?

I was trying to load them through a restart - in my case since I´m using Docker simply Stop and Start the Container.

Yes you would have to restart.

Does it show up if you try to add a new integration through Configuration->Integrations?

It is supposed to import your YAML configuration, but would be interesting to see if it is even showing up there.

If I filter on Add Integration for something like Flux or LED it is not showing up.
What exactly do you mean by it is supposed to import my yaml configuration?
Do I have to add another specific line in there?
Currently - regarding to Flux - I just have the autodetect Block like mentoined in my first posting.

configuration.yaml print:

# Configure a default setup of Home Assistant (frontend, api, etc)

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

  broker: XXX
  port: 1883
  client_id: XXX
  username: XXX
  password: XXX
  client_id: XXX
  client_secret: XXX

  - platform: flux_led
    automatic_add: true

  - platform: xiaomi_miio
    host: XXX
    token: XXX
    name: XXX

Thanks for your Help!

Once it is installed it should import the configuration from the YAML and move it into the Integrations page. You don’t need the entry in configuration.yaml once it is installed.

You may want to go from the PR to my repository and grab the entire flux_led folder for that branch to make sure you get all the files. I’m running it as a custom component and it is working on mine.

Maybe paste a screen shot of the custom_components/flux_led folder.

My god I´m so sorry I´m an Idiot and copied the full Pull from git in the custom Components.
Now with the files in components\flux_led to the correct dir I do have the Icon in the Integration Configuration.
New Behaviour: I do not see the Light anymore even with auto detect also tried to enter the IP Address manually with the Integration UI but the Device still do not seem to appear.
Also not in Configuration -> Devices

Is there anything else to try on this point?

Sorry again! Like mentoined I´m brand new with Home Assistant basically first day :slight_smile:

Any chance anyone have another Idea for this topic?
I don´t get this to work and don´t know what to try else.

Help would be really appreciated!

How you got further with your LED strip working with HF-LPB100 ?
I have a power plug from CHACON using same chip.
How can I hook up this in Home assistant?

Support for the newer devices (except for the addressable kind) should be available in 2021.11