"LED Light bulb" with Magic Home app" integration?

Has anyone successfully integrated one of these? The bulb is on my Wifi, works correctly with the Magic Home app. Tried to use Alexa integration but the Skill “can’t be enabled right now, try later”.

From what I see, it should work with Flux_led component, but it doesn’t. I tried various modes and protocols, but log only says

Failed to connect to bulb 192.168.0.98, DiningTable

IP is correct. Any clues? Thanks!

3 Likes

I got the same issue :frowning:

I have same issue…I think…I’m a total noob and my first attempt at connecting anything to a new build was these bulbs. Nothing even detected by HA. I’ve googled around and believe I needed to modify the configuration.yaml file, so bumbled around and managed to install ‘file editor’ and add the following to that file

light:

  • platform: flux_led
    automatic_add: true

but so far no hint of anything being detected.
Any help would be great. (ie are you seeing the devices but cant make them work?)

Flux integration doesn’t work. Therea are two brands that use indentically named but completely different apps called Magic Home. Flux doesn’t work with this one.

Hi. I have the same problem. the solution that i find y use google assistant
I install de add-on Assistant Relay

entities:
  - action_name: Broadcast
    name: relay luz patio enciende
    service: rest_command.assistant_relay
    service_data:
      command: turn on bulb

its not a solution but its works

1 Like

I got lost throughout the process but I’ll try again, this looks interesting. I love complicated solutions to simple problems :slight_smile: Thanks!

Id love to get a resolve to this - im not smart enough to work out how to get it to link properly and control the lights on the LoveLace UI.

Anyone able to help that would be great!

1 Like

having used the setup function - it looks a though the bulb may be one of these?

https://www.ibroadlink.com/products/smart-bulb

trying to find out how to get that setup…

If you’re brave enough to open up the bulb and discover that its using an ESP8266 chip, by far the best way is to flash the Tasmota firmware onto the chip (its easier than it sounds, hardest part is physically connecting the bulb to the RasPi/USB). Disclaimer: I have no idea if this bulb uses ESP8266, but the common LED strip controllers certainly do use it.

I flash all of my MagicHome devices with Tasmota using a RasPi, although they are LED strip controllers which are pretty easy to open.

Alternatively you can probably solve this problem without flashing by using IFTTT Webhooks.

I’ve flashed Tasmota many times, I didn’t know this could be an ESP8266 bulb. I’ll open it and try, nothing to lose really. Thanks!

I have no idea but if its a lost cause then def worth a shot! Interested to know what you find, post some pics :slight_smile:

1 Like

Anyone have progress?

Have you made any progress?

No. Just buy a different bulb :slight_smile:

Tried flashing it as a Tasmoto device over wifi?

Aparently this bulbs are ibroadlink devices…
This python can identify bulbs on my network, but does not control that yet.

Would also love to get support for such devices (I own a few…)

UP!

Anyone have progress?

Up! Just purchased a few bulbs and found out too late that it cant be integrated to HA.

You can try this, should work assuming I have the same bulbs as you.

You can “control” them through HA but you will have to use MQTT commands and a python program constantly running either on a separate computer or if you can, the same system that is running HA, to act as a MQTT client.

The python program will act as a bridge. There is a library for these bulbs specifically and it works very well. Of course it’s local control too. Use pip to install the library python-magichue. Then get paho-mqtt (also through pip if you would like). You will have to come up with your own way formatting the MQTT messages.

For my program, it simply takes an MQTT string separated by ‘,’ and has 6 parameters. “BulbID, r, g, b, w, state” where BulbID is what bulb to change (The bulbID correlates to a line in a text file that contains the IPs of all bulbs in my house) and the state is
0 = off, 1 = on, and 2 = toggle on/off.

If anyone would like I can give the code for it. Not sure if I can do it by attachment or not though.