LED Lights that actually work

So I choose blue and get green. I want red and I get red & green…
Anyone had these issues before?

I’m actually not sure if its the strip or the controller at this point.
Half the strip wants to light and have tried the controller on another strip.
Tried the strip on other controllers.

1 Like

Yes, I too have the same problem.
I assume its the strip problem & not controller.
Solution in my mind:

  1. What I am planning to do is swap the wires of the Green & Red (In my case) in the connector & test it.(99.9% it should work)
  2. I have set Green as Red & red as Green in my HA UI, hence as of now choosing colors from UI for any home member is not a problem. They get the right color.

Again above point 2 is not valid while using Google home as it will set Red if we say Green

Hey thanks for that info.
I never really considered they would have wired them incorrectly.

So upon investigation the wires don’t actually match the sequence that is on the strip!
The strip has +BGR on it and the wires are in White, Green, Red and Blue order.
I assume this is my issue and I shall solider tomorrow!

1 Like

Please let me know once done

Thought we had something but no changes after re wiring.
Still have parts of the strip not coming on and wrong colours still.

I think it is the strip itself now. Tried with different controllers.
Unless somehow the controllers and the strip aren’t compatible somehow.

I have the same setup at my place with several of these cheap led’s (different brands) and same mini controller. I have LED strips with (+,B,G,R) and (GND,B,G,R) and they all work on the controller. I only have 1 LED strip (+,B,G,R) where the wire color does not match but it works as labeled (maybe cheap production issue)

Your described issue was killing me in the beginning and took me a while to figure out. In the end I was able to narrow it down to the used power supply.

I think I have tried about 10-15 power supplies, all with different effects. Some were working at once but failing over time. Others failed to show the correct color (or kept blinking) at once.

I have now found a cheap Chinese power supply (5v/2a) for about $3 which works really well with all my lights.

I’m no electrician but on a rainy Sunday I was spending some time measuring the other power supplies and I realized that these devices were not able to keep the ampere amount above 1A when switching on, when switching color or on high brightness.

After using this power supply I never had issues with the controllers and any led strip.

When having part of the LED strip not working it can be a break in the wiring or a defect led and I solved it with the following steps

  1. Identify from where the LED is not working properly anymore and cut the strip after the last working LED
  2. connect the LED controller to the other end of the LED strip
  3. Identify the last working LED and cut the LED strip after this LED
  4. now you should have 2 working LED strips
  5. You can use a LED-Strip connector (10pcs ~2$) to combine the strips back again … or use them individually

I used the above approach several times when a LED-strip got broken during installation and it always worked for me.

Ok so a power supply issue it seems…
Thanks for the info because I couldn’t work it out. Thought the cables were wired incorrectly but labeled incorrectly seems to make sense after my experiments.

I tried different plugs to get it working and realised they are 12 volt LEDs and I mixed up my plugs. What a stupid mistake! My 12 volt plug and the 5v plugs look the same and sure enough… so they weren’t getting the right voltage.

Now they are on a proper power supply they work fine. After soldiering the wires the “correct way” turns out they were mislabelled this entire time and work correctly.

I’m saving money rather than going the Phillips hue way etc but definitely was head scratching.

More to the point the controller is literally a controller so assuming it would supply the correct voltage was a stupid assumption too

yes, the controller is a stupid little thing, but does a great job if setup correctly. I’m running LED-strips with upto 15m (900 LEDs) and had only to adjust the power supply to get it working :sunglasses:

It sounds like the wattage of the power supply is not enough. Every led strip has a requirement in wattage. For example a led strip could use 10watts per meter. Another would need 20watts per meter.
You have to know what wattage consumption your led strip has and then multiply all the meters you have connected.
So if your led strip is in total 5 meters and it needs 10 watts per meter then 5*10=50 watts power supply.
changing the wiring would do nothing if the power supply is not efficient. Try only a meter or two of led strip and it will work just fine. Or get another (larger) supply.

I have the same issue with Osram light strips and I think the reason is that they are technically different from LED bulbs. All colors starting from orange tend towards green. On the other hand the strips produce a perfect green that is not achievable with bulbs.

I had an issue ages ago with rgb strips not lighting up to the correct colour using the remote. I used this video to solve my issue. Maybe something like this will help?

For me it was a combination of wiring issues and incorrect power supply for the strip. Going really well. Hopefully soon will have the controllers running on MQTT.

I swapped the wires it works great now