Ledvance WiFi bulbs

hi guys,
on ubuntu 18.4 with command

frida-trace -U --decorate -j ‘*!encodeString/isu’ -F

i obtain always

Started tracing 0 functions. Press Ctrl+C to stop.

I tried with single quotes, double quotes, no quote…nothing

i try

adb shell “ps”
and find
but if i try
frida-trace -U -i open com.ldvsmartwifi.smart
Failed to spawn: unable to find process with name ‘com.ldvsmartwifi.smart’
works with
frida-trace -U -i open com.android.chrome

Some help?


Hi all,

I follow Flag tutorial, but when I launch the Frida command, after few seconds, I got the message “No frontmost application on Android Emulator 5554”.

All installations seems fine as when I do the command " frida-ps -U", I got the display of all android processes.

As the LDV apk link seems broken, I download version 1.2.0 from another site. Login to the app is fine and it is in foreground.

Any help please ?

EDIT : manage to make it work with command “adb root” before installing Frida. Thanks a lot for the guide !

where do i create input_number.h_input , input_number.s_input , input_number.temperature_input in HA? i’ve got it to work, but the temperature and the color doesent work.

Everything worked out great! Now I’m standing there with my read-out localKeys and don’t know how to integrate them into HA. :no_mouth:

Thanks for help


this solution works also for Ledvance Smart+ Plug Wifi!!!
The tutorial with the Android SDK works fine.
Start of tutorial.

I was getting the same message: “Started tracing 0 functions. Press Ctrl+C to stop.”

After hours I came up with this solution.

frida-trace -U --decorate -j *!*encodeString*/is -F

1 Like

i think i could love you :smiley:


you have to install local tuya, its an addon that you find in hacs or you have to install it manually, when your home assistant isnt in Supervisor mode (like in a docker container)

I m sadly not able to run frida on my pc, all i get is

Failed to load the Frida native extension: DLL load failed while importing _frida:

how can i fix this i tried different python versions and different frida versions

i tried it with the recommended python version 3.9.6 and it worked, thanks

Hi FrancYescO :slight_smile:

Thanks for the guide, I now can see the JSON that the android app is generating in the console!

LocalTuya configuration requires both the device_id and the local_key, I see the localKey in the json, but the closest thing to device_id that I can see is devId, which has a similar value to key and bizId in the same JSON, it is also the same as the Virtual ID value that you can find in the LDV WiFi app itself for this bulb, but when I try using that as the device_id I’m not able to get a successful connection with the bulb and it’s greyed out in the Lovelace dashboard!

Do you have a tip for me.?! :slight_smile:

i can confirm that what you see as Virtual ID in the app is what you need, why is greyed out i don’t know, maybe looking at some debug information on localtuya can help you, are you sure to have not mixed localkey from various device?

do you, guys think this same approach is going to work for this ledvance light? It says on the datasheet it also uses the Ledvance smart+ wifi app so I’m guessing it will work…

This is the product description SMART + WIFI ORBIS Donut 400 WT - and this is the datasheet

If it uses the same app, pretty sure yes.

yup, worked like a charm, indeed!

I have been at this for 3 hours…

I am SO close. But i keep getting
“No frontmost application on Android Emulator 5554”

frida-trace --version

adb shell
generic_x86_arm:/ #

When i look at the app version on the virtual phone it shows as version 1.2.0?
I followed the link from HowTo - Ledvance SMART+ Plug Wifi in Home Assistant (Solution)

Also, no matter what i do i keep getting
“Unable to locate adb” when i start the AVD. But isnt ADB working when i am able to install the app?


i had to open the shell with
adb shell
and then run these two commands “manually”

chmod 755 /data/local/tmp/frida-server
/data/local/tmp/frida-server &

Then it worked

BTW. I am trying to integrate LEDVANCE GARDEN POLE RGB + WHITE

These are my settings in local Tuya

Great work guys!

I was able to trace in powershell but my JS bloob does not contain any localkeys…


Edit: I managed to find key, had to refresh devices multiple times

Hi Flag - I’ve been trying this for a day now and can’t get “add root” to execute. Normally comes back with “can’t run in production modes” or something. Can you help?

Hi @Flag - I’ve gotten pretty far now but have the same two issues.

  1. adb shell /data/local/tmp/frida-server &
    Always says cant because it’s a directory

  2. frida-trace -U --decorate -j *!encodeString/isu -F
    Always returns “No frontmost application on Android Emulator 5554”

I have the emulator running with the app and I can see my devices so I’m not sure what’s wrong at this point.

Please help!

Hi Frank,

try to run the comman one by one.

first: adb shell (press enter) and then the other commands line by line!

Do you haave the right Android Version in the emulator running?
With the first tutorial, i got crazy because many steps are not included. I spent days with trial and error. Today, wouldnt buy theese plugs and would take better one with zigbee.