Legrand Nuvo multi-room audio support

2024-01-14 11:55:31.259 WARNING (SyncWorker_3) [homeassistant.loader] We found a custom integration nuvo_serial which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant

2024-01-14 11:55:31.260 WARNING (SyncWorker_3) [homeassistant.loader] We found a custom integration nodered which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant

2024-01-14 11:55:31.261 WARNING (SyncWorker_3) [homeassistant.loader] We found a custom integration hacs which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant

2024-01-14 11:55:31.332 INFO (MainThread) [homeassistant.setup] Setup of domain logger took 0.0 seconds

2024-01-14 11:55:31.333 INFO (MainThread) [homeassistant.bootstrap] Setting up frontend: {‘frontend’}

2024-01-14 11:55:31.344 INFO (MainThread) [homeassistant.setup] Setting up device_automation

2024-01-14 11:55:31.344 INFO (MainThread) [homeassistant.setup] Setup of domain device_automation took 0.0 seconds

2024-01-14 11:55:31.407 INFO (MainThread) [homeassistant.setup] Setting up lovelace

2024-01-14 11:55:31.409 INFO (MainThread) [homeassistant.setup] Setting up http

2024-01-14 11:55:31.410 INFO (MainThread) [homeassistant.setup] Setup of domain lovelace took 0.0 seconds

2024-01-14 11:55:31.417 INFO (MainThread) [homeassistant.setup] Setup of domain http took 0.0 seconds

2024-01-14 11:55:31.426 INFO (MainThread) [homeassistant.setup] Setting up api

2024-01-14 11:55:31.429 INFO (MainThread) [homeassistant.setup] Setup of domain api took 0.0 seconds

2024-01-14 11:55:31.430 INFO (MainThread) [homeassistant.setup] Setting up auth

2024-01-14 11:55:31.430 INFO (MainThread) [homeassistant.setup] Setup of domain auth took 0.0 seconds

2024-01-14 11:55:31.437 INFO (MainThread) [homeassistant.setup] Setting up config

2024-01-14 11:55:31.445 INFO (MainThread) [homeassistant.setup] Setting up diagnostics

2024-01-14 11:55:31.453 INFO (MainThread) [homeassistant.setup] Setting up repairs

2024-01-14 11:55:31.453 INFO (MainThread) [homeassistant.setup] Setup of domain repairs took 0.0 seconds

2024-01-14 11:55:31.522 INFO (MainThread) [homeassistant.setup] Setup of domain config took 0.1 seconds

2024-01-14 11:55:31.522 INFO (MainThread) [homeassistant.setup] Setup of domain diagnostics took 0.1 seconds

2024-01-14 11:55:31.532 INFO (MainThread) [homeassistant.setup] Setting up file_upload

2024-01-14 11:55:31.532 INFO (MainThread) [homeassistant.setup] Setup of domain file_upload took 0.0 seconds

2024-01-14 11:55:31.570 INFO (MainThread) [homeassistant.setup] Setting up image_upload

2024-01-14 11:55:31.572 INFO (MainThread) [homeassistant.setup] Setting up websocket_api

2024-01-14 11:55:31.572 INFO (MainThread) [homeassistant.setup] Setup of domain websocket_api took 0.0 seconds

2024-01-14 11:55:31.572 INFO (MainThread) [homeassistant.setup] Setup of domain image_upload took 0.0 seconds

2024-01-14 11:55:31.575 INFO (SyncWorker_3) [homeassistant.loader] Loaded group from homeassistant.components.group

2024-01-14 11:55:31.576 INFO (SyncWorker_2) [homeassistant.loader] Loaded device_tracker from homeassistant.components.device_tracker

2024-01-14 11:55:31.577 INFO (MainThread) [homeassistant.setup] Setting up person

2024-01-14 11:55:31.605 INFO (MainThread) [homeassistant.setup] Setting up search

2024-01-14 11:55:31.605 INFO (MainThread) [homeassistant.setup] Setup of domain search took 0.0 seconds

2024-01-14 11:55:32.197 INFO (MainThread) [homeassistant.setup] Setting up analytics

2024-01-14 11:55:32.199 INFO (MainThread) [homeassistant.setup] Setup of domain analytics took 0.0 seconds

2024-01-14 11:55:32.201 INFO (MainThread) [homeassistant.setup] Setup of domain person took 0.6 seconds

2024-01-14 11:55:32.203 INFO (MainThread) [homeassistant.setup] Setting up onboarding

2024-01-14 11:55:32.203 INFO (MainThread) [homeassistant.setup] Setup of domain onboarding took 0.0 seconds

2024-01-14 11:55:32.206 INFO (MainThread) [homeassistant.setup] Setting up frontend

2024-01-14 11:55:32.209 INFO (MainThread) [homeassistant.setup] Setup of domain frontend took 0.0 seconds

2024-01-14 11:55:32.210 INFO (MainThread) [homeassistant.bootstrap] Setting up recorder: {‘recorder’}

2024-01-14 11:55:32.212 INFO (MainThread) [homeassistant.setup] Setting up recorder

2024-01-14 11:55:32.223 INFO (MainThread) [homeassistant.components.http] Now listening on port 8123

2024-01-14 11:55:32.246 INFO (MainThread) [homeassistant.setup] Setup of domain recorder took 0.0 seconds

2024-01-14 11:55:32.248 INFO (MainThread) [homeassistant.bootstrap] Setting up stage 1: {‘ssdp’, ‘bluetooth’, ‘zeroconf’, ‘cloud’, ‘network’, ‘api’, ‘websocket_api’, ‘hassio’, ‘webhook’, ‘http’, ‘usb’, ‘dhcp’}

2024-01-14 11:55:32.251 INFO (MainThread) [homeassistant.setup] Setting up hassio

2024-01-14 11:55:32.262 INFO (MainThread) [homeassistant.setup] Setting up webhook

2024-01-14 11:55:32.262 INFO (MainThread) [homeassistant.setup] Setup of domain webhook took 0.0 seconds

2024-01-14 11:55:32.268 INFO (MainThread) [homeassistant.setup] Setting up network

2024-01-14 11:55:32.269 INFO (MainThread) [homeassistant.setup] Setup of domain network took 0.0 seconds

2024-01-14 11:55:32.290 INFO (MainThread) [homeassistant.setup] Setting up usb

2024-01-14 11:55:32.291 INFO (MainThread) [homeassistant.setup] Setup of domain usb took 0.0 seconds

2024-01-14 11:55:32.342 INFO (MainThread) [homeassistant.setup] Setting up dhcp

2024-01-14 11:55:32.342 INFO (MainThread) [homeassistant.setup] Setup of domain dhcp took 0.0 seconds

2024-01-14 11:55:32.351 INFO (SyncWorker_2) [homeassistant.loader] Loaded google_assistant from homeassistant.components.google_assistant

2024-01-14 11:55:32.352 INFO (SyncWorker_2) [homeassistant.loader] Loaded alexa from homeassistant.components.alexa

2024-01-14 11:55:32.356 INFO (SyncWorker_0) [homeassistant.loader] Loaded camera from homeassistant.components.camera

2024-01-14 11:55:32.356 INFO (SyncWorker_0) [homeassistant.loader] Loaded matter from homeassistant.components.matter

2024-01-14 11:55:32.413 INFO (MainThread) [homeassistant.setup] Setting up zeroconf

2024-01-14 11:55:32.419 INFO (MainThread) [homeassistant.setup] Setup of domain zeroconf took 0.0 seconds

2024-01-14 11:55:32.557 INFO (MainThread) [homeassistant.setup] Setting up bluetooth

2024-01-14 11:55:32.569 INFO (MainThread) [homeassistant.components.zeroconf] Starting Zeroconf broadcast

2024-01-14 11:55:32.573 INFO (SyncWorker_3) [homeassistant.loader] Loaded media_player from homeassistant.components.media_player

2024-01-14 11:55:32.618 INFO (MainThread) [homeassistant.setup] Setup of domain bluetooth took 0.1 seconds

2024-01-14 11:55:32.650 INFO (MainThread) [homeassistant.setup] Setting up ssdp

2024-01-14 11:55:32.661 INFO (MainThread) [homeassistant.setup] Setup of domain hassio took 0.4 seconds

2024-01-14 11:55:34.604 INFO (MainThread) [homeassistant.setup] Setting up cloud

2024-01-14 11:55:34.607 INFO (MainThread) [homeassistant.setup] Setup of domain ssdp took 2.0 seconds

2024-01-14 11:55:34.660 INFO (MainThread) [homeassistant.setup] Setup of domain cloud took 0.1 seconds

2024-01-14 11:55:34.755 INFO (MainThread) [homeassistant.setup] Setting up ffmpeg

2024-01-14 11:55:34.885 INFO (MainThread) [homeassistant.setup] Setup of domain ffmpeg took 0.1 seconds

2024-01-14 11:55:34.888 INFO (MainThread) [homeassistant.setup] Setting up tts

2024-01-14 11:55:34.893 INFO (MainThread) [homeassistant.setup] Setup of domain tts took 0.0 seconds

2024-01-14 11:55:35.853 INFO (SyncWorker_1) [homeassistant.loader] Loaded binary_sensor from homeassistant.components.binary_sensor

2024-01-14 11:55:35.854 INFO (SyncWorker_3) [homeassistant.loader] Loaded update from homeassistant.components.update

2024-01-14 11:55:35.855 INFO (SyncWorker_1) [homeassistant.loader] Loaded sensor from homeassistant.components.sensor

2024-01-14 11:55:35.856 INFO (MainThread) [homeassistant.setup] Setting up binary_sensor

2024-01-14 11:55:35.856 INFO (MainThread) [homeassistant.setup] Setup of domain binary_sensor took 0.0 seconds

2024-01-14 11:55:35.861 INFO (MainThread) [homeassistant.setup] Setting up update

2024-01-14 11:55:35.861 INFO (MainThread) [homeassistant.setup] Setup of domain update took 0.0 seconds

2024-01-14 11:55:35.869 INFO (MainThread) [homeassistant.setup] Setting up sensor

2024-01-14 11:55:35.870 INFO (MainThread) [homeassistant.setup] Setup of domain sensor took 0.0 seconds

2024-01-14 11:55:35.876 INFO (MainThread) [homeassistant.components.binary_sensor] Setting up hassio.binary_sensor

2024-01-14 11:55:35.877 INFO (MainThread) [homeassistant.components.update] Setting up hassio.update

2024-01-14 11:55:35.877 INFO (MainThread) [homeassistant.components.sensor] Setting up hassio.sensor

2024-01-14 11:55:35.886 INFO (MainThread) [homeassistant.bootstrap] Setting up stage 2: {‘script’, ‘file_upload’, ‘mobile_app’, ‘hacs’, ‘automation’, ‘google_translate’, ‘ffmpeg’, ‘trace’, ‘system_health’, ‘wake_word’, ‘schedule’, ‘radio_browser’, ‘map’, ‘diagnostics’, ‘lovelace’, ‘input_button’, ‘input_number’, ‘application_credentials’, ‘assist_pipeline’, ‘nodered’, ‘stream’, ‘repairs’, ‘input_boolean’, ‘image_upload’, ‘input_text’, ‘default_config’, ‘device_automation’, ‘tts’, ‘hardware’, ‘counter’, ‘shopping_list’, ‘my’, ‘homeassistant_alerts’, ‘history’, ‘tag’, ‘persistent_notification’, ‘onboarding’, ‘search’, ‘cast’, ‘stt’, ‘media_source’, ‘input_select’, ‘auth’, ‘sun’, ‘zone’, ‘conversation’, ‘analytics’, ‘person’, ‘input_datetime’, ‘config’, ‘blueprint’, ‘energy’, ‘scene’, ‘timer’, ‘logbook’}

2024-01-14 11:55:35.891 INFO (MainThread) [homeassistant.setup] Setting up trace

2024-01-14 11:55:35.891 INFO (MainThread) [homeassistant.setup] Setup of domain trace took 0.0 seconds

2024-01-14 11:55:35.892 INFO (MainThread) [homeassistant.setup] Setting up wake_word

2024-01-14 11:55:35.892 INFO (MainThread) [homeassistant.setup] Setup of domain wake_word took 0.0 seconds

2024-01-14 11:55:35.896 INFO (MainThread) [homeassistant.setup] Setting up schedule

2024-01-14 11:55:35.897 INFO (MainThread) [homeassistant.setup] Setting up input_button

2024-01-14 11:55:35.898 INFO (MainThread) [homeassistant.setup] Setting up input_number

2024-01-14 11:55:35.900 INFO (MainThread) [homeassistant.setup] Setting up input_boolean

2024-01-14 11:55:35.901 INFO (MainThread) [homeassistant.setup] Setting up input_text

2024-01-14 11:55:35.920 INFO (MainThread) [homeassistant.setup] Setting up hardware

2024-01-14 11:55:35.926 INFO (MainThread) [homeassistant.setup] Setting up counter

2024-01-14 11:55:35.945 INFO (MainThread) [homeassistant.setup] Setting up homeassistant_alerts

2024-01-14 11:55:35.945 INFO (MainThread) [homeassistant.setup] Setup of domain homeassistant_alerts took 0.0 seconds

2024-01-14 11:55:35.989 INFO (MainThread) [homeassistant.setup] Setting up history

2024-01-14 11:55:35.989 INFO (MainThread) [homeassistant.setup] Setup of domain history took 0.0 seconds

2024-01-14 11:55:36.001 INFO (MainThread) [homeassistant.setup] Setting up tag

2024-01-14 11:55:36.002 INFO (MainThread) [homeassistant.setup] Setting up stt

2024-01-14 11:55:36.002 INFO (MainThread) [homeassistant.setup] Setup of domain stt took 0.0 seconds

2024-01-14 11:55:36.003 INFO (MainThread) [homeassistant.setup] Setting up input_select

2024-01-14 11:55:36.004 INFO (MainThread) [homeassistant.setup] Setting up sun

2024-01-14 11:55:36.004 INFO (MainThread) [homeassistant.setup] Setup of domain sun took 0.0 seconds

2024-01-14 11:55:36.005 INFO (MainThread) [homeassistant.setup] Setting up zone

2024-01-14 11:55:36.006 INFO (MainThread) [homeassistant.setup] Setting up conversation

2024-01-14 11:55:36.006 INFO (MainThread) [homeassistant.setup] Setup of domain conversation took 0.0 seconds

2024-01-14 11:55:36.008 INFO (MainThread) [homeassistant.setup] Setting up input_datetime

2024-01-14 11:55:36.009 INFO (MainThread) [homeassistant.setup] Setting up blueprint

2024-01-14 11:55:36.009 INFO (MainThread) [homeassistant.setup] Setup of domain blueprint took 0.0 seconds

2024-01-14 11:55:36.010 INFO (MainThread) [homeassistant.setup] Setting up scene

2024-01-14 11:55:36.012 INFO (MainThread) [homeassistant.setup] Setting up timer

2024-01-14 11:55:36.014 INFO (SyncWorker_0) [homeassistant.loader] Loaded mqtt from homeassistant.components.mqtt

2024-01-14 11:55:36.016 INFO (MainThread) [homeassistant.setup] Setup of domain hardware took 0.1 seconds

2024-01-14 11:55:36.021 INFO (MainThread) [homeassistant.setup] Setting up system_health

2024-01-14 11:55:36.034 INFO (MainThread) [homeassistant.setup] Setting up map

2024-01-14 11:55:36.034 INFO (MainThread) [homeassistant.setup] Setup of domain map took 0.0 seconds

2024-01-14 11:55:36.047 INFO (MainThread) [homeassistant.setup] Setting up application_credentials

2024-01-14 11:55:36.050 INFO (MainThread) [homeassistant.setup] Setting up shopping_list

2024-01-14 11:55:36.050 INFO (MainThread) [homeassistant.setup] Setup of domain shopping_list took 0.0 seconds

2024-01-14 11:55:36.061 INFO (MainThread) [homeassistant.setup] Setting up my

2024-01-14 11:55:36.061 INFO (MainThread) [homeassistant.setup] Setup of domain my took 0.0 seconds

2024-01-14 11:55:36.063 INFO (MainThread) [homeassistant.setup] Setting up media_source

2024-01-14 11:55:36.067 INFO (MainThread) [homeassistant.setup] Setting up energy

2024-01-14 11:55:36.067 INFO (MainThread) [homeassistant.setup] Setup of domain energy took 0.0 seconds

2024-01-14 11:55:36.078 INFO (MainThread) [homeassistant.setup] Setting up logbook

2024-01-14 11:55:36.090 INFO (MainThread) [homeassistant.setup] Setup of domain input_button took 0.2 seconds

2024-01-14 11:55:36.092 INFO (MainThread) [homeassistant.setup] Setup of domain input_number took 0.2 seconds

2024-01-14 11:55:36.093 INFO (MainThread) [homeassistant.setup] Setup of domain schedule took 0.2 seconds

2024-01-14 11:55:36.094 INFO (MainThread) [homeassistant.setup] Setup of domain input_boolean took 0.2 seconds

2024-01-14 11:55:36.105 INFO (MainThread) [homeassistant.setup] Setting up assist_pipeline

2024-01-14 11:55:36.105 INFO (MainThread) [homeassistant.setup] Setting up script

2024-01-14 11:55:36.106 INFO (MainThread) [homeassistant.setup] Setting up automation

2024-01-14 11:55:36.166 INFO (MainThread) [homeassistant.setup] Setting up hacs

2024-01-14 11:55:36.167 INFO (MainThread) [homeassistant.setup] Setup of domain hacs took 0.0 seconds

2024-01-14 11:55:36.168 INFO (MainThread) [homeassistant.setup] Setting up google_translate

2024-01-14 11:55:36.168 INFO (MainThread) [homeassistant.setup] Setup of domain google_translate took 0.0 seconds

2024-01-14 11:55:36.175 INFO (MainThread) [homeassistant.setup] Setup of domain system_health took 0.2 seconds

2024-01-14 11:55:36.180 INFO (MainThread) [homeassistant.setup] Setup of domain media_source took 0.1 seconds

2024-01-14 11:55:36.184 INFO (MainThread) [homeassistant.setup] Setup of domain script took 0.1 seconds

2024-01-14 11:55:36.185 INFO (MainThread) [homeassistant.setup] Setup of domain automation took 0.1 seconds

2024-01-14 11:55:36.185 INFO (MainThread) [homeassistant.setup] Setup of domain logbook took 0.1 seconds

2024-01-14 11:55:36.187 INFO (MainThread) [custom_components.hacs]


HACS (Home Assistant Community Store)

Version: 1.33.0

This is a custom integration

If you have any issues with this you need to open an issue here:


2024-01-14 11:55:36.196 INFO (MainThread) [homeassistant.setup] Setup of domain input_text took 0.3 seconds

2024-01-14 11:55:36.197 INFO (MainThread) [homeassistant.setup] Setup of domain counter took 0.3 seconds

2024-01-14 11:55:36.198 INFO (MainThread) [homeassistant.setup] Setup of domain tag took 0.2 seconds

2024-01-14 11:55:36.199 INFO (MainThread) [homeassistant.setup] Setup of domain input_select took 0.2 seconds

2024-01-14 11:55:36.744 INFO (MainThread) [homeassistant.setup] Setting up radio_browser

2024-01-14 11:55:36.744 INFO (MainThread) [homeassistant.setup] Setup of domain radio_browser took 0.0 seconds

2024-01-14 11:55:36.745 INFO (MainThread) [homeassistant.components.scene] Setting up homeassistant.scene

2024-01-14 11:55:36.750 INFO (SyncWorker_2) [homeassistant.loader] Loaded todo from homeassistant.components.todo

2024-01-14 11:55:36.767 INFO (MainThread) [homeassistant.setup] Setup of domain input_datetime took 0.8 seconds

2024-01-14 11:55:36.768 INFO (MainThread) [homeassistant.setup] Setup of domain application_credentials took 0.7 seconds

2024-01-14 11:55:36.769 INFO (MainThread) [homeassistant.setup] Setup of domain timer took 0.8 seconds

2024-01-14 11:55:36.772 INFO (MainThread) [homeassistant.setup] Setup of domain scene took 0.8 seconds

2024-01-14 11:55:36.780 INFO (MainThread) [homeassistant.setup] Setup of domain zone took 0.8 seconds

2024-01-14 11:55:36.789 INFO (MainThread) [homeassistant.setup] Setup of domain assist_pipeline took 0.7 seconds

2024-01-14 11:55:36.793 INFO (MainThread) [homeassistant.setup] Setting up todo

2024-01-14 11:55:36.794 INFO (MainThread) [homeassistant.setup] Setup of domain todo took 0.0 seconds

2024-01-14 11:55:36.796 INFO (MainThread) [homeassistant.setup] Setting up stream

2024-01-14 11:55:36.867 INFO (MainThread) [homeassistant.setup] Setup of domain stream took 0.1 seconds

2024-01-14 11:55:36.870 INFO (MainThread) [homeassistant.components.sensor] Setting up energy.sensor

2024-01-14 11:55:36.890 INFO (SyncWorker_0) [homeassistant.loader] Loaded notify from homeassistant.components.notify

2024-01-14 11:55:36.903 INFO (MainThread) [homeassistant.setup] Setting up nodered

2024-01-14 11:55:36.903 INFO (MainThread) [homeassistant.setup] Setup of domain nodered took 0.0 seconds

2024-01-14 11:55:36.905 INFO (MainThread) [custom_components.nodered]


Node-RED Companion

Version: 3.1.3

This is a custom integration!

If you have any issues with this you need to open an issue here:


2024-01-14 11:55:36.905 INFO (MainThread) [homeassistant.components.sensor] Setting up sun.sensor

2024-01-14 11:55:36.907 INFO (SyncWorker_3) [homeassistant.loader] Loaded plex from homeassistant.components.plex

2024-01-14 11:55:37.098 INFO (MainThread) [homeassistant.setup] Setting up mobile_app

2024-01-14 11:55:37.109 INFO (MainThread) [homeassistant.setup] Setup of domain mobile_app took 0.0 seconds

2024-01-14 11:55:37.114 INFO (MainThread) [homeassistant.setup] Setting up notify

2024-01-14 11:55:37.114 INFO (MainThread) [homeassistant.setup] Setup of domain notify took 0.0 seconds

2024-01-14 11:55:37.121 INFO (MainThread) [homeassistant.setup] Setting up device_tracker

2024-01-14 11:55:37.127 INFO (MainThread) [custom_components.hacs] Restore started

2024-01-14 11:55:37.143 INFO (MainThread) [homeassistant.components.notify] Setting up notify.mobile_app

2024-01-14 11:55:37.175 INFO (MainThread) [homeassistant.setup] Setup of domain device_tracker took 0.1 seconds

2024-01-14 11:55:37.280 INFO (MainThread) [custom_components.hacs] Restore done

2024-01-14 11:55:37.281 INFO (MainThread) [custom_components.hacs] Enable category: integration

2024-01-14 11:55:37.281 INFO (MainThread) [custom_components.hacs] Enable category: plugin

2024-01-14 11:55:37.282 INFO (MainThread) [custom_components.hacs] Enable category: template

2024-01-14 11:55:37.282 INFO (MainThread) [custom_components.hacs] Enable category: theme

2024-01-14 11:55:37.282 INFO (MainThread) [custom_components.hacs] Using experimental frontend

2024-01-14 11:55:37.336 INFO (MainThread) [homeassistant.setup] Setting up cast

2024-01-14 11:55:37.337 INFO (MainThread) [homeassistant.setup] Setup of domain cast took 0.0 seconds

2024-01-14 11:55:37.344 INFO (MainThread) [homeassistant.setup] Setting up media_player

2024-01-14 11:55:37.352 INFO (MainThread) [homeassistant.setup] Setup of domain media_player took 0.0 seconds

2024-01-14 11:55:37.365 INFO (MainThread) [homeassistant.components.tts] Setting up google_translate.tts

2024-01-14 11:55:37.370 INFO (MainThread) [homeassistant.components.todo] Setting up shopping_list.todo

2024-01-14 11:55:37.372 INFO (MainThread) [homeassistant.components.sensor] Setting up mobile_app.sensor

2024-01-14 11:55:37.372 INFO (MainThread) [homeassistant.components.binary_sensor] Setting up mobile_app.binary_sensor

2024-01-14 11:55:37.373 INFO (MainThread) [homeassistant.components.device_tracker] Setting up mobile_app.device_tracker

2024-01-14 11:55:37.373 INFO (MainThread) [homeassistant.components.sensor] Setting up hacs.sensor

2024-01-14 11:55:37.376 INFO (MainThread) [homeassistant.components.update] Setting up hacs.update

2024-01-14 11:55:37.383 WARNING (MainThread) [homeassistant.helpers.entity] Entity None (<class ‘custom_components.hacs.update.HacsRepositoryUpdateEntity’>) is using deprecated supported features values which will be removed in HA Core 2025.1. Instead it should use <UpdateEntityFeature.INSTALL|PROGRESS|RELEASE_NOTES: 21>, please create a bug report at Issues · hacs/integration · GitHub and reference Deprecating all magic numbers for supported features | Home Assistant Developer Docs

2024-01-14 11:55:37.384 WARNING (MainThread) [homeassistant.helpers.entity] Entity None (<class ‘custom_components.hacs.update.HacsRepositoryUpdateEntity’>) is using deprecated supported features values which will be removed in HA Core 2025.1. Instead it should use <UpdateEntityFeature.INSTALL|PROGRESS|RELEASE_NOTES: 21>, please create a bug report at Issues · hacs/integration · GitHub and reference Deprecating all magic numbers for supported features | Home Assistant Developer Docs

2024-01-14 11:55:37.386 WARNING (MainThread) [homeassistant.helpers.entity] Entity None (<class ‘custom_components.hacs.update.HacsRepositoryUpdateEntity’>) is using deprecated supported features values which will be removed in HA Core 2025.1. Instead it should use <UpdateEntityFeature.INSTALL|PROGRESS|RELEASE_NOTES: 21>, please create a bug report at Issues · hacs/integration · GitHub and reference Deprecating all magic numbers for supported features | Home Assistant Developer Docs

2024-01-14 11:55:37.389 INFO (MainThread) [homeassistant.components.media_player] Setting up cast.media_player

2024-01-14 11:55:37.389 INFO (MainThread) [custom_components.hacs] Stage changed: setup

2024-01-14 11:55:37.390 INFO (MainThread) [custom_components.hacs] Stage changed: waiting

2024-01-14 11:55:37.390 INFO (MainThread) [custom_components.hacs] Setup complete, waiting for Home Assistant before startup tasks starts

2024-01-14 11:55:37.438 INFO (MainThread) [homeassistant.setup] Setting up default_config

2024-01-14 11:55:37.439 INFO (MainThread) [homeassistant.setup] Setup of domain default_config took 0.0 seconds

2024-01-14 11:55:37.663 INFO (MainThread) [homeassistant.bootstrap] Home Assistant initialized in 6.41s

2024-01-14 11:55:37.664 INFO (MainThread) [homeassistant.core] Starting Home Assistant

2024-01-14 11:55:37.673 INFO (MainThread) [custom_components.hacs] Stage changed: startup

2024-01-14 11:55:37.725 INFO (MainThread) [custom_components.hacs] Loading removed repositories

2024-01-14 11:55:37.727 INFO (SyncWorker_0) [homeassistant.loader] Loaded apple_tv from homeassistant.components.apple_tv

2024-01-14 11:55:37.732 INFO (zeroconf-ServiceBrowser-_googlecast._tcp-104) [homeassistant.components.cast.helpers] Fetched cast details for unknown model ‘D65x-G4’ manufacturer: ‘Vizio’, type: ‘cast’. Please create a bug report at Issues · home-assistant/core · GitHub

2024-01-14 11:55:38.108 INFO (SyncWorker_2) [homeassistant.loader] Loaded denonavr from homeassistant.components.denonavr

2024-01-14 11:55:38.840 INFO (MainThread) [custom_components.hacs] Loading known repositories

2024-01-14 11:55:38.977 INFO (MainThread) [custom_components.hacs] Stage changed: running

This is the log I get when I restart HA.

It’s looking like a basic communication error when trying to open /dev/ttyUSB0 at connect time. Is this a HAOS vmware image you’re using? I don’t use vmware or HAOS so can only give you general guidelines.

I assume your host OS is Windows and you installed the Nuvo sw in it to load the default config ok, so your serial to USB cable is working.

There must be settings in vmware to pass through the USB device of the cable from the host OS to the HA Guest VM and have it automatically do this every time the VM is started or if the cable is reinserted. Have you done this and verified that /dev/ttyUSB0 is the correct device name to use inside the VM?

HAOS is a linux based VM so if it gives you access to the VM boot logs, have a look for the serial port name in there.

If there’s a cli/console/ssh access into the VM, shortly after boot try:

dmesg | grep -i tty

at the command line to find it.

This is the response I get when running dmesg. I did verify in the settings and hardware section of HAOS that ttyUSB0 is connected.

[ 0.000000] Command line: BOOT_IMAGE=(hd0,gpt4)/bzImage root=PARTUUID=a3ec664e-32ce-4665-95ea-7ae90ce9aa20 rootwait zram.enabled=1 zram.num_devices=3 systemd.machine_id=a16955a5535b4dd382dcff4ffa9bdab4 fsck.repair=yes console=ttyS0 console=tty1 rauc.slot=B
[ 0.096699] Kernel command line: BOOT_IMAGE=(hd0,gpt4)/bzImage root=PARTUUID=a3ec664e-32ce-4665-95ea-7ae90ce9aa20 rootwait zram.enabled=1 zram.num_devices=3 systemd.machine_id=a16955a5535b4dd382dcff4ffa9bdab4 fsck.repair=yes console=ttyS0 console=tty1 rauc.slot=B
[ 0.142899] printk: console [tty1] enabled
[ 0.738964] printk: console [ttyS0] enabled
[ 2.580944] 00:05: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
[ 4.399437] systemd[1]: Created slice Slice /system/serial-getty.
[ 7.137331] usb 3-1: pl2303 converter now attached to ttyUSB0
[ 12.630930] audit: type=1300 audit(1705714754.170:100): arch=c000003e syscall=44 success=yes exit=40 a0=c a1=c000bff620 a2=28 a3=0 items=0 ppid=1 pid=441 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=“dockerd” exe=“/usr/bin/dockerd” subj=unconfined key=(null)
[ 12.839006] audit: type=1300 audit(1705714754.388:101): arch=c000003e syscall=321 success=yes exit=15 a0=5 a1=c000131988 a2=78 a3=0 items=0 ppid=828 pid=838 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=“runc” exe=“/usr/bin/runc” subj=unconfined key=(null)
[ 12.839260] audit: type=1300 audit(1705714754.388:102): arch=c000003e syscall=321 success=yes exit=17 a0=5 a1=c000131720 a2=78 a3=0 items=0 ppid=828 pid=838 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=“runc” exe=“/usr/bin/runc” subj=unconfined key=(null)
[ 17.727115] audit: type=1300 audit(1705714759.189:146): arch=c000003e syscall=46 success=yes exit=528 a0=3 a1=7ffcfa549990 a2=0 a3=7ffcfa54997c items=0 ppid=441 pid=1257 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=“iptables” exe=“/usr/sbin/xtables-nft-multi” subj=unconfined key=(null)
[ 17.729598] audit: type=1300 audit(1705714759.191:147): arch=c000003e syscall=46 success=yes exit=508 a0=3 a1=7ffdd8247f90 a2=0 a3=7ffdd8247f7c items=0 ppid=441 pid=1258 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=“iptables” exe=“/usr/sbin/xtables-nft-multi” subj=unconfined key=(null)
[ 18.015552] audit: type=1300 audit(1705714759.472:148): arch=c000003e syscall=44 success=yes exit=40 a0=c a1=c001642e70 a2=28 a3=0 items=0 ppid=1 pid=441 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=“dockerd” exe=“/usr/bin/dockerd” subj=unconfined key=(null)
[ 51.318513] audit: type=1300 audit(1705714792.686:196): arch=c000003e syscall=321 success=yes exit=15 a0=5 a1=c00018d988 a2=78 a3=0 items=0 ppid=2653 pid=2664 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=“runc” exe=“/usr/bin/runc” subj=unconfined key=(null)
[ 51.318732] audit: type=1300 audit(1705714792.687:197): arch=c000003e syscall=321 success=yes exit=17 a0=5 a1=c00018d720 a2=78 a3=0 items=0 ppid=2653 pid=2664 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=“runc” exe=“/usr/bin/runc” subj=unconfined key=(null)
[ 51.318977] audit: type=1300 audit(1705714792.687:200): arch=c000003e syscall=321 success=yes exit=15 a0=5 a1=c00018dbe0 a2=78 a3=0 items=0 ppid=2653 pid=2664 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=“runc” exe=“/usr/bin/runc” subj=unconfined key=(null)

So I figured out what was wrong. My Grand Concerto had been powered on for a while so I started off by unplugging it for a while then plugging it back in due to reading that someone else here also had to do that. After trying to reconnect I started to get an invalid source response from the “party”. I went into the setting of the Grand Concerto through the software and disabled party and paging. Once doing that the next response I got was invalid zone volume. I once again went into the settings and changed my max volume from “0dB” to “-10 dB”. After doing that once I entered /dev/ttyUSB0 into the port I was then prompted with a new window to setup the Grand Concerto!

Reviving this thread a bit. It’s not clear to me if there was ever a viable solution for the Concerto model NV-18DM. It seems like the media player listed here might work, and the homebridge solution also seems promising. But I don’t see definitive answers in the relevant documents for each product.

I’m trying to revive my home automation system that’s been offline for a few years. I’m running HA in a docker on a qnap NAS, but am likely to do a native install on a NUC I have that’s just sitting idle.

If the NV-18DM isn’t an option, what’s the best model to go trolling for on eBay? I’d be open to alternative solutions at that point.

TIA !

Reviving this thread a bit. It’s not clear to me if there was ever a viable solution for the Concerto model NV-18DM. It seems like the media player listed here might work, and the homebridge solution also seems promising. But I don’t see definitive answers in the relevant documents for each product.

It appears the original Concerto model pretty much resembles the others of its time such as the Essentia D and Simplese. It just has quite a few more features. I think the nuvo-simple integration could be adapted quite easily to support the basics. What are you trying to accomplish? Are you using keypads? Do you need full media controls such as play, stop, etc. This would only be really necessary if you have other players on the NuvoNet bus.

Nuvo T2-SIR tuner support

Reviving this thread reminds me I pretty much finished a tuner integration for the Nuvo T2-SIR and it could probably support others fairly easily. Supports radio RDS and Sirius Artist/Title display. I reverse engineered the configuration dump so it is able to pull all presets, favorites, and Sirius channels directly from the tuner. I’ll get it put on github eventually, if there is any interest let me know. I know it’s old by today’s standards but still quite useful, at least for me anyway.

I have a T2-SIR sitting in the closet… wouldn’t mind breaking it out and see what you have built for it.

My use case is pretty simple. I have a Sonos (gasp) driving one input, an Alexa driving another input, and a third input from a software media player. I only have a few outputs; garage, patio, etc. No keypads. I just need to be able to turn outputs off/on, set volumes, set inputs. That’s about it.

I used to have everything driven through a Charmed Quark install, but have let that go stale since it went open source. No correlation other than timing.

I’ve updated nuvo-simple to (hopefully) support Concerto. It has the basic controls anyway.

I’ll get nuvo-tuner out this week.

I had never heard of Charmed Quark before, I read up on it a little bit. Looks like a lot of history there.

Tons of history, and Dean poured years of blood, sweat, and tears into the product. Ultimately, he had to pass it out to the community and find other reliable means of living :slight_smile:

It seemed like I could post a question and 7 out of 10 times he’d answer within 2 hrs… didn’t matter what time of the 24hr day it was. I was really sad to see he had to give up on it. I had a nice touchscreen interface setup in my rack, and media cover art swipe mode on my iPad. I could pick a movie and hit play and fire off a whole macro (I had a few choices). One was ‘play now’, another was ‘play with intro’, another was ‘gimme five first’. It would then fire up the media equipment, pick the right source (Roku, Bluray, DVD). It even knew which of my two Sony 400 disc players and slot to play. It would dim lights, set the right zoom/aspect ratio for my projector, play intros, etc.

It was a bit of a learning curve, but the interface designer was pretty solid. 3rd party drivers weren’t too complicated to write for those in the know.

Anyhow, I appreciate your responses here and I’ll take a look at the simple version you referenced. I just got my HA setup back online with a repurposed NUC. Rebuilt my ZWave. Adding a few garage door sensors; already integrated one here on the countertop… just need to move it to the garage and set the wiring.

Are there any recommended devices for running multiple audio out? And software players for that matter too? I used to have a turtle beach card in a full size media pc with 8? stereo outs? But that project’s long gone too.

PS, I might need a primer on how to install something outside of a UI supported install. Is there a generic HA ‘howto’ for things like this?

Okay, figured out the integration part. That was surprisingly simple after a few Google searches. Now I need to get my serial connections back online. That’ll take me a little bit; I don’t think I have a straight USB to RS232 cable; I was previously using a digiport 8 port that lost a power supply I haven’t replaced.

CQC looked like a nice product for sure. It seems to still be somewhat active even though the main site is down now. Dean certainly seemed dedicated and obviously took care of it like a child. It is certainly sad to see it discontinued. I still see some people are using CQC and then having it talk to HA for things it doesn’t have the drivers for and so forth.

However, it’s not all bad with HA. As long as someone out there has something they want to make work with it and has a little programming knowledge, it’s not too hard to do. There’s only a few of us though that have these Nuvo products I guess. I remember when installing mine years ago when building my home is that it would be something I could probably use practically forever since it has it’s own protocol and serial port. I don’t like any hardware on the cloud because the support never seems to last for too long.

The lovelace is pretty good for making usable interfaces. You can run HA on your iPad and it will work really well. Building what you describe does sound complex though for sure. It would take some custom programming to do some of that. Even if nothing exists, you can easily add shell scripts to run other programs, or there are simple things built in to send data to a serial port for instance. I have an Optoma projector and have been wanting to write an integration for that, but never have got around to it. Getting all of the media into a catalog might be tricky. I’m not sure what could show a picture of a movie and say “This is on DVD player 2, disc 300.” I’d say you could get some help with the community here though.

As far as multiple audio outs, HA does, in my opinion, a pretty bad job of supporting anything locally like that. There’s very little support for sound cards, or at least one with multiple outputs. I am using a USB “sound card” on my server for some things, but it’s just one output. I have the announcements setup on it (also using the Nuvo paging service for that), Pandora integration, and Music Assistant. It might be possible to get multiple outputs to work, however I just never really tried. It seems most don’t use any sound card locally at all, everything is just a streaming device. What I ended up doing was using a couple of Chromecast Audio devices as well. HA can stream to those easily, and just about any music app on any cell phone (most people’s preferred way these days) will work with it too.

Since you seem like me and have a lot of your own music, take a look at Music Assistant. It can help you out there.

It sounds like you are well on your way to getting HA setup and working somewhat, so that is great. To answer your next post, you will need a USB to RS232 adapter unless your NUC has a serial port on it. I hope to add nuvo-simple into the main HACS without the custom repo soon, but for now here is the page for it and how to add it into HA.

I did add the main Concerto features like power, volume, source, bass, treble, and balance but it’s still limited.

[GitHub - brmccrary/nuvo_simple]

Thanks Brian,

I got Github connected last night. Amazon hooked me up with an overnight 4 port USB hub and usb to serial cable. I have that installed and proxmox shared to my HASS VM. Now I need to try and figure out how to get it configured. I haven’t seen anything on that yet.

I did a quick drop in of your yaml file edit, but think I’m missing something still. I don’t see any integrations other than the default ones that come with the GitHub connection. And I get what look like syntax errors in the naming scheme in the config yaml file.

<edit #3> I now seem to have the yaml configured correctly, or at least I’m not getting any errors. I see the variables on the overview page, but I’m not finding the device to configure cards etc.

Thanks for all the help so far.

RE: my previous setup. Dean had his own media repositories, and he could also hook into some of the more common catalogers. So my repository pulled down cover art and all the production goodies from IMDB. Those catalogers usually have an app too, and a camera hook so you can just bar code scan your media. So the catalogue knew the aspect ratio and all the other important stuff. I had stored multiple zoom/tilt settings in my JVC projector, so my script simply matched against the aspect ratio and knew which setting to go to. Most everything else was straight macro commands. The repository also knew what player and disc slot each of the DVD’s was in; another concatenate command to play that player:disc. Those Sony 777 series had a nice rs232 command set that would straight bypass all the intro stuff if you told it to; straight to play.