How to add VLC into my Hassio?

I use command line
“sudo apt-get install vlc-nox”,
“sudo usermod -a -G audio homeassistant”,
but no sudo with Hassio.
How to add VLC into my Hassio?

Hassio uses Alpine, so just apk add vlc should work.

I tried. no worked.

Curious about this too. Using the SSH addon for hassio, there’s no apt-get or usermod as far as I can tell. Has anyone successfully installed VLC with hassio?

It is not possible to install packages on You’ll need to create an add-on to run an application besides Home Assistant:

It is not possible to have applications interact directly with Home Assistant. You can have add-ons communicate via MQTT

it works on my pi 3B ,thanks

in ubuntu and other linux

the problem is alsa!! e.g. sudo apt-get install vlc-nox and alsa-utils in HAdocker
the alsa Mutes individual channels by default . use alsamixer to available sounds

Now it is possible!

You can install VLC on your hassio system using this add-on:

And control it using the vlc-telnet integration:



Hello @rodripf,

sorry but it doesnt work for me :

[0000007fbda37ad0] dbus interface error: Failed to connect to the D-Bus session daemon: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
[0000007fbda37ad0] main interface error: no suitable interface module
[0000007fbdb81b50] main libvlc error: interface "dbus,none" initialization failed
[0000007fbda64830] main interface error: no suitable interface module
[0000007fbdb81b50] main libvlc error: interface "globalhotkeys,none" initialization failed
[0000007fbda6d9e0] main playlist: playlist is empty
[0000007fbda379a0] [telnet] lua interface: Listening on host "telnet://:4212".
[0000007fbda667f0] [http] lua interface: Lua HTTP interface
[0000007fbda6d9e0] main playlist: playlist is empty
[0000007fbda6d9e0] main playlist: playlist is empty
[0000007fbda6d9e0] main playlist: playlist is empty
[0000007fbda6d9e0] main playlist: playlist is empty

what does it mean please?

How solved it please?


what is telnet password? Where do I set it?

Take a look here:

has anyone tried using the official VLC addon? i dont see a place to configure the password with the official addon

Yes, it seems like you can configure VLC password only if VLC is running on different machine. Documentation is very unclear about that

I haven’t yet, but plan on trying it out soon. Just doing my research. My challenge is that my home assistant instance is running on a VM in ProxMox and I need to be able to make sure that I can Passthrough the built in sound card. I may need to install a dedicated audio card to make it work properly.

However I do believe that I can answer your question regarding the password for telnet. I quickly reviewed the GitHub repo and here are two code snippets that I found.

There is a a script that looks for a file called “data/secret”, if it does not exist. It creates one and generates a new random password using the pwgen tool.

#!/usr/bin/with-contenv bashio
# ==============================================================================
# Create VLC secret
# ==============================================================================

if bashio::fs.file_exists /data/secret; then

# Generate password
pwgen 64 1 > /data/secret

Here is another code snippet that instantiates VLC as a daemon

readonly PASSWORD="$(cat /data/secret)"

# Send out discovery information to Home Assistant
./discovery &

# Run daemon
exec cvlc -I http --extraintf telnet --http-host --http-password "INGRESS" --telnet-password "${PASSWORD}" --aout=pulse

If we look at the code snippet we can see that the contents of /data/secret are passed to the variable PASSWORD. Then further down the variable “PASSWORD” is referenced when passing the telnet-password argument.

If for some reason you needed the password, you could extract it from /data/secret. However seeing as I haven’t looked any further, I am not sure under what conditions that file might be changed/overwritten/delete and therefore change the password. For example this might occur during a reboot or upgrade.

Please note that I am not a programmer, I simply dabble and occasionally edit other peoples code to suit my purposes… So if my understanding or terms used are incorrect, feel free to correct me.

There is an official VLC add-on in the Settings > Add-ons > ADD_ON STORE.

This installs and runs the add-on under the HA OS. You may have to configure its inputs and outputs in the add-on’s Configuration tab. Then you start it (check the log tab for errors and if all looks good, enable the watchdog and start on boot).

With the add-on running (and this part is key), you go to Settings > Devices & Services, and should have the VLC telnet integration auto-discovered. You add it and there’s not much to do. Everything should just work out of the box - or at least it did for me on 3 HA OS installs so far.

If you’ve some VLC integration manual install pre-dating this, you may have to take it out and clean that up very thoroughly and redo this procedure.