Lenovo smart plug SE-341A

Hi all, new guy here, lurked here a little, worked up the courage to finally post, please be gentle.

Grabbed one of these these smart plugs recently but I can’t get the damn thing to work with home assistant.

It’s Wi-Fi and appears on my network fine. Works with the Lenovo app but obviously having to use it in that manner defeats it’s purpose for my intentions. Have tried to connect to it via the tuya app with no success whatsoever.

I’m running hassio on a pi if that makes a difference.

I’ve struggled to find information on this device. Any help would be greatly appreciated.



Did you ever find a solution to this? I’m facing the same problem.

No, I don’t have a solution, mine is packed away and unused to this day. Until now nobody ever responded and I couldn’t find answers anywhere else.

I found this community to be a tough nut to crack, maybe I didn’t follow the correct protocol but the few times I asked for help I was completely ignored so I stopped bothering.

Hopefully you’ll have more luck that I did.

I cracked this a couple of days ago. Connect the switch with the Lenovo app, then go in to the device settings and do a firmware update. Mine came with 2.3.1 and was updated to 4.0.0.

When starting the update it will prompt you about needing to use the Lenovo Pro app to connect from that point on. Once the update is complete you’ll be able to add the smart plug in the Tuya app, I added it as “Socket (Wi-Fi)”.

You’ll then be able to control the device through Home Assistant with the tuya integration.


That’s great. It’s good to be able to finally use it. Cheers.

This still works.

Thank you for the information.