Let's Encrypt - Invalid Response on ACME challenge

I’m trying to use let’s encrypt (without DuckDNS) but I keep getting the following error.

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] file-structure.sh: executing... 
[cont-init.d] file-structure.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[17:27:03] INFO: Selected http verification
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for homeassistant.redacted.com
Waiting for verification...
Challenge failed for domain homeassistant.redacted.com
http-01 challenge for homeassistant.redacted.com
Cleaning up challenges
Some challenges have failed.
 - The following errors were reported by the server:
   Domain: homeassistant.redacted.com
   Type:   unauthorized
   Detail: Invalid response from
   [2607:f1c0:100f:f000::2c7]: 204
   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

This is my configuration for Let’s Encrypt.

email: [email protected]
  - homeassistant.redacted.com
certfile: fullchain.pem
keyfile: privkey.pem
challenge: http
dns: {}

My external URL is https://homeassistant.redacted.com

Currently I have port forwarding set to

80 => 80
443 => 443
8123 => 8123

Based on other posted I’ve tried a number of things. For my external URL I’ve tried https and http. I tried appending :80 and :8123. For port forwarding I’ve tried 443 => 8123 and 443 => 80.

One comment in a post suggested putting the port for the external URL on a separate line in configuration.yaml. However, I’m not sure if the port should be 80, 443, or 8123. More importantly, I have no idea the syntax to use in configuration.yaml. So far I’ve just used the GUI.

Can someone help?


I’m trying to fix my https now and nothing works. But I can`t use 80 port is busy and I’ve set 82 port in settings, but seems like it is still using 80 while trying to renew the certificate.

Did you solve this problem?

I needed to clear browser cache and it worked? at least I had access to Hass with certificate errors