Letsencrypt issues

dont know what i have done. but after setting up the certs and everything is working great.
90days is coming up. so i follow the directions to update all looks good. but when checking the site externally it using the old cert. but when check the IP from in my network it is using the updated cert?
also noticed that when im on the external site there is not version number on HASS but there is on the internal.
getting totally lost. would just start from scratch but i dont want to end up in the same boat.

please help.

Try clearing your browser cache. I remember a few versions back having the issue where the version number was blank, in addition to a few other issues. Clearing the cache cleared it all up.

Yeah - especially if you’re using Chrome. CTRL-F5 to force a refresh.

Worked it out. Totally forgot i had tried setting up nginx. Late last year. Didnt think i had it work. Was tring to proxy some other stuff as well. It was using the old cert. So uninstalled. All good now.