Letsencrypt Problem

hi, im having a bit of problem getting letsencrypt to work. maybe someone can help.
I’ve tried Bruh’s tut because the tutorial on the HA site is very confusing.
here is my problem:

  1. If I run this as the user “homeassistant” it will ask me for a password, which I do not have it. I tried leaving it blank, tried my HA password from setup and tried my password from mqtt. after 3 tries it resets.
    then I exit that user and go back to the “Pi” user.

  2. As the “pi” user, everything goes fine. but I get this error on the confi log.

> "2017-07-01 12:56:37 ERROR (MainThread) [homeassistant.config] Invalid config for [http]: not a file for dictionary value @ data[‘http’][‘ssl_certificate’]. Got ‘/etc/letsencrypt/live/mydomain/fullchain.pem’
_> not a file for dictionary value @ data[‘http’][‘ssl_key’]. Got ‘/etc/letsencrypt/live/mydomain/privkey.pem’."

then i check the folders with command:

“ls /etc/letsencrypt/live/”

and it says

“cannot access /etc/letsencrypt/live/: No such file or directory”

so what am I doing wrong?
with user homeassistant it ask for a password I dont know
with user Pi it does not create the necessary folders.

Never mind…
It seems that was an error during the installation that I didnt see.
So, I created a new domain from noip and reran the installation and it worked.