Leviton Z-Wave Plus switches/Dimmers No configuration options


#1

I have mostly Leviton switches, pretty much all of which were ‘unknown’. I learned about adding the xml files and modifying the manufacturer_specific file, and did so before I added the first DZ6HD dimmer to my network. This one, when in OZWCP, I select it and go to ‘configuration’ down below, I see most or all of the configurable options there. But none of my subsequently added DZ6HD dimmers have the config options. My Aeotec Nano switch also shows configuration options. A few of my DZ15S switches have ‘Locator LED Status’, but some don’t. I’ve been using the same files found here for the DZ6HD, here for the DZ15S and here for the GE fan switch.

Of course the manufacturer_specific file with the info for these switches got replaced between the last ones I added and the ones I added today (most likely when I updated to the version I’m on now), so the new ones are ‘Unknown GE’ and ‘Unknown Leviton’.

From what I’ve found, once the device has been included, there’s no modifying/updating this information. You must exclude it and then re-include it, which in my case gets it a new ID.

Is there some way I’m missing to update this information? Any ideas why, despite using the same files, one dimmer has the advanced config options, but the others don’t? I’d like to get this all fixed, but I don’t want to go remove and include all my swiches and dimmers, because that will result in them all getting new IDs and having to re-do my entire automation.


#2

Update to 54 as it gets you latest openzwave release

Once upgrade done and running write down the switches you want to update node Id and node name if you customized them

Shutdown home assistant

Edit your Zwcfg xml file and delete the sections for the node ids above.

Restart ha and wait while it enumerates your zwave network - maybe 10 minutes or so

Go into Config and Zwave and find the node ids you wrote down and rename them - do this for all.

Then shutdown again and restart

You now Should have those switches proper setup with the most current released manufactures data and options displayed


#3

Thanks - I’ll give that a shot a little later.


#4

So I updated to 0.54.0 and it did apparently update OpenZWave, however, unfortunately, is didn’t bring anything in regarding my DZ6HD and DZ15S switches. The files from the Open Z-Wave alliance were still there, so I put my manufacturer_specific.xml file that knows what to do with the DZ6HD and did what you suggested and removed one node for testing. After all was said and done, same thing.

I probably should have been clearer, though, I’ve never used the Z-Wave functions through HASS - I’ve always stopss HASS and started the OZWCP on 8888 and made my changed that way - so far, my attempts to add devices through HASS have been… less than successful. OZWCP has worked every time. :man_shrugging:

A Picture is worth a thousand words…

In OZWCP, this is what I get with the very first DZ6HD switch I added:
Node33.md.jpg

With all subsequent DZ6HD dimmers, I get this:
Node55.md.jpg

I did poke around in HASS and checked out the Z-Wave config options, and I get the same thing. I can see and change config options for Node33. There are no config parameters for node 55 that I removed from the OZW config file and let HASS re-enumerate with the config files still present.


#5

I ended up comparing the data for node 33 and node 55, and what I came up with was the following.

The two devices sections withing the xml file were the same except for the IDs and these sections:

Node 33 had the following:


33group.jpg
33Version.jpg

Node 55 had the following:
55Config.jpg
55Group.jpg
55Version.jpg

Sorry, I’m posting screen clips because I can’t seem to past the code so it ends up properly formated and each section is separate - most other forums I’ve been on code /code (in brackets) does the trick, but here that messes up the formatting.

So I manually modified the config sections for all the other DZ6HDs, copying in the data from the one that apparently got all the right data (what a pain in the butt) and now all the DZ6HDs have all the config options.

But it would be nice to know why the first one got all the right settings, but none of the subsequent ones…

More importantly, after seeing the config options there in HASS, I stopped it and started OZWCP, then ran the ‘initialize’.

Apparently, it didn’t use the data in the xml as a starting point because it still didn’t know anything about the configuration options for the other DZ6HDs - so I fear that next time I add a node, it might overwrite my changes that make the options appear for the dimmers.

Edit: I take the bit about the config files back - sort of. When I updated, it did pull all the things I removed to clean it up because I didn’t’ have any of the devices or brands (figured I’d add them back should I ever add one of them), but when I poked around their GitHub, I found that there are DZ6HD, DZ15S and DZPD3 xml files. There is a lot less in them than there is in the ones from Z-Wave Alliance, mostly info/notes, but one thing in particular I noticed is the ones from ZWave Alliance seem to be lacking ‘CommandClass id=“133”’, for example, which is present in the ones from OpenZWave. One would think the ones on Github would be based off the ones from Z-Wave Alliance and either would work - I’ll have to test out with the ones from OpenZWave.


#6

This is odd as that DZ6HD is listed and has a support file in the latest update included with HA.


#7

I copied the appropriate files from the zip I grabbed from the OpenZWave Git repository up to my HASS server and modified the manufacturer_specific.xml to reference those instead of the ones I got from the Z-Wave Alliance pages, stopped HASS, started OZWCP and initialized it, and same thing - the original one gives me the configuration, but not the subsequent ones. very strange…


#8

Does anyone have working config for any of the leviton z-wave scene controllers? I have several of the VRCS4-M0Z (https://www.leviton.com/en/products/vrcs4-m0z) associated (worked great under vera) and I’m seeing messages in the debug when buttons are pushed, but I see zero way to connect them to events/triggers/etc.

Example:

2018-03-11 21:19:02.275 Detail, Node038, Received: 0x01, 0x15, 0x00, 0x49, 0x84, 0x26, 0x0f, 0x02, 0x01, 0x00, 0x85, 0x2d, 0x7c, 0x77, 0x82, 0x73, 0x86, 0x72, 0x91, 0xef, 0x2b, 0x2c, 0xd2
2018-03-11 21:19:02.276 Detail,
2018-03-11 21:19:02.276 Info, Node038, UPDATE_STATE_NODE_INFO_RECEIVED from node 38
2018-03-11 21:19:02.276 Detail, Node038, AdvanceQueries queryPending=0 queryRetries=0 queryStage=Dynamic live=1
2018-03-11 21:19:02.277 Detail, Node038, QueryStage_Dynamic
2018-03-11 21:19:02.277 Detail, Node038, QueryStage_Configuration
2018-03-11 21:19:02.278 Detail, Node038, QueryStage_Complete
2018-03-11 21:19:02.278 Warning, CheckCompletedNodeQueries m_allNodesQueried=0 m_awakeNodesQueried=1
2018-03-11 21:19:02.279 Warning, CheckCompletedNodeQueries all=0, deadFound=1 sleepingOnly=1
2018-03-11 21:19:02.279 Detail, Node038, Notification: NodeQueriesComplete
2018-03-11 21:19:02.373 Detail, Node038, Received: 0x01, 0x09, 0x00, 0x04, 0x08, 0x26, 0x03, 0x20, 0x01, 0xff, 0x01
2018-03-11 21:19:02.373 Detail,
2018-03-11 21:19:02.373 Info, Node038, Received Basic set from node 38: level=255. Sending event notification.
2018-03-11 21:19:02.373 Detail, Node038, Notification: NodeEvent
2018-03-11 21:19:02.502 Detail, Node038, Received: 0x01, 0x09, 0x00, 0x04, 0x08, 0x26, 0x03, 0x20, 0x01, 0xff, 0x01
2018-03-11 21:19:02.502 Detail,
2018-03-11 21:19:02.503 Info, Node038, Received Basic set from node 38: level=255. Sending event notification.
2018-03-11 21:19:02.504 Detail, Node038, Notification: NodeEvent
2018-03-11 21:19:02.730 Detail, Node038, Received: 0x01, 0x09, 0x00, 0x04, 0x08, 0x26, 0x03, 0x20, 0x01, 0xff, 0x01
2018-03-11 21:19:02.731 Detail,
2018-03-11 21:19:02.731 Info, Node038, Received Basic set from node 38: level=255. Sending event notification.
2018-03-11 21:19:02.732 Detail, Node038, Notification: NodeEvent
2018-03-11 21:19:03.023 Detail, Node038, Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x26, 0x03, 0x20, 0x01, 0xff, 0x09
2018-03-11 21:19:03.024 Detail,
2018-03-11 21:19:03.024 Info, Node038, Received Basic set from node 38: level=255. Sending event notification.
2018-03-11 21:19:03.025 Detail, Node038, Notification: NodeEvent

Ideally we’d have a way to configure each button for which scene to trigger, and be able to control the LED’s under each button.


#9

How did I miss this guide?