LG Smartthinq Air Conditioning

Ok, based off that, I am using the same auth_base, api_root and oath_root URLs, so I hope that means it will all work for me, as it does for you.

1 Like

So just to chime in here again…at least in my case, when I ran the original “v1” wideq, I got no return from the cli, but in the .json file I got essentially the same as Keiran posted above. When I ran the “v2” wideq, I got similar, but also a bunch of stats on my AC unit from temp, to mode, etc, etc.

Using v1, I got no errors in HA (just a warning I was using a custom component that could break in future updates), but also no devices added. V2 should work, but then no idea how to make things use that version instead, and simply replacing the wideq folders with the new one did nothing.

As for v1 vs v2, all I can say is I made my account back around June 2020, and could authenticate to both, so logins seem to work independent of each. But again, I only got a device return on v2, so maybe it forks depending on which device is accessed within an account? (eg. a new account can make calls to either api depending on device in the official app, if that makes any sense)

How About a Step by Step from very beginning to the end thanks

Hi,
First, If you are using hassio ( Check by configuration -> Info -> Hassio = true ) I cant help you, because I dont know how to run python command :sweat_smile:
So, prepare some tool for using ssh command, file editor ( FILE EDITOR addon ) and some basic knowledge of python and start with https://github.com/sampsyo/hass-smartthinq , follow the instructions step by step. When you run below command

$ python3 example.py -c US -l en-US

If you got SSL error like my previous question, just edit the file in the picture of my last post.
After that, if you got an error like " permission " lets try again with the command below

$ sudo python3 example.py -c US -l en-US

If everything right, you will get an file name wideq_state.json in wideq folder. At this moment 90% of work complete. Just follow the next step in the link.
Because of some AC model in different country have different function so they will not work with sampsyo code, you need to remove some line of his code for your AC can work. If you got error, just post here and every one can help you.

I am using venv and those steps does not work it does nothing

I am guessing something got lost in translation this is what I mean by step by step

I built this page to help with python 3.9 install on a raspberry pi this is what I mean by step by step

3.9 tutorial

or my Tutorial for installing Home Assistant in the first place
Home Assistant with File Sharing

the garbage that is on sampsyo can’t even get past the first step

[email protected]:~ $ cd ~/.homeassistant
-bash: cd: /home/pi/.homeassistant: No such file or directory
[email protected]:~ $

My Home assistant Configuration

System Health

arch x86_64
dev false
docker false
hassio false
installation_type Home Assistant Core
os_name Linux
os_version 4.19.0-12-amd64
python_version 3.9.0
timezone America/Edmonton
version 0.117.6
virtualenv true

Lovelace

dashboards 2
mode storage
resources 4
views 10

If you got any order laptop or PC, try WinSCP software for create and copy the file to custom_components folder.

it is already there I manually copied it into that folder

can’t understand why people have to be so cryptic on how they got something to work

I am not a programmer yet I am happy to write down the steps from the start to the finish to help others

these instructions that say do this but does not tell you how you get to the point to do that step in the first place is straight up useless

Easy up Trenton. Theres 100’odd posts above of people doing exactly that - helping. Calling the guy who wrote this integration garbage is outta line. Check yourself mate, its not in the spirit of the community.

Whatever way you cut it, dabbling with this sort of stuff will eventually require you to know some basic linux skills. How to ssh. How to change around directories. How to copy files. How to run a python script from the command line. Theres a gazillion tutorials around for this sort of stuff. If you dont want to do that then maybe hass isnt right for you right now.

Its like joining a mechanics club and getting frustrated when people dont tell you how to use a screwdriver, there is a level of assumed knowledge.

We will help, but stay polite dude.

2 Likes

In terms of your problem, maybe rephase it by saying “im stuck on step 1 please help” to which i would reply “try this command- configuration.yaml is a standard file across hass installations, so the find command will help you locate its path”


So in my case, if i didnt know where my hass directory was, i do now… its /_LOCALDATA/CONTAINERS/hass/ so then type “cd /_LOCALDATA/CONTAINERS/hass/ “ and there is your step1.
See how you go.

I know where my configuration file is, I know how to SSH into and I know how to reach the custom folder, the GARBAGE instructions the sampsy guy wrote is worthless, the vanguyen guy gives the impression he found the missing steps and decides to be cryptic for whatever reason and you come on here whining about my post because you are offended and decide to be condescending just to agitate the thread awesome

Wow. Good luck with that buddy. I gave you your step1, but if you cant see that, Im out. Maybe take a walk and cool down hey?

1 Like

The 1st step is just for clone or copy smartthinq folder from github to your HA, if that not work, just ignore that Sh*t, then using a laptop, download the file, using winSCP or any other software with fpt client for copy and paste the smartthinq folder to your HA custom_components folder
That all, goodluck.

as I stated before I have those in my custom folder if you don’t want to help sharing what steps you did to get the thing to work then fine don’t help!

With your attitude I’m surprised anyone is offering help

well I tried the nice method earlier in the thread and got no response so there is that

For the next poor bastard that finds issues just to get the WideQ to work here is the steps for that.
SSH into your home assistant and copy the stuff below and paste if you are using putty or another client that allows paste, below is for the virtualenv type install no idea if it will work on other platforms

sudo -u homeassistant -H -s
cd /srv/homeassistant
python3 -m venv .
cd ~/.homeassistant
cd custom_components
cd wideq
python3 example.py -c US -l en-US

After you run this it will return a Link to copy and paste that into your browser to log into your LG account you will need your user name and password along with country code that you used to create the account, leave the SSH as it is for it is waiting for the refreshed token after you log in, it is the complete address in the browser is what you want to copy back and paste in your SSH client then hit enter

I finally figured out the steps to at least get this far hope this helps I am still trying to muck my own way through this I will keep posting up the steps involved as I discover them

As any example, your instruction are somewhat useless for me. Do you see the problem here?

You appear to use venv, while others will not. I for example use Home Assistant Core (docker container).

These forums are full of smart (and friendly) people. But they can also be busy with their own lives and don’t check the forums all the time. Be polite, be patient, and you will enjoy your time in the community.

And I State that it is for venv platform in the beginning , vunguyen indicated the he was using venv is why I asked for step by step, and instead I get a cryptic response, as you can see with missing steps stuff don’t work well thus useless, no worries I have two AC units to figure out how to install , right now I am still trying to add them to home assistant as entities so I can build cards, I know better than to ask here because I won’t get a good answer from anyone here. and yes you are correct there is a lot of friendly and smart people on this forum that has helped a lot on some off the wall stuff, however in this thread not so much the ones here rather play cryptic games I understand that life happens I waited weeks for answers on questions and some times takes a while to give answers in what I can help with that is not the issue.

All my fail is not good at English to describe clearly for you :sweat_smile: :sweat_smile: