LG webos integration stopped working on 2023.1

I have an LG TV that has been neatly integrated with the standard webos media player integration.

I upgraded to 2023.1 from a 2022.12 today and all of the sudden this integration stopped working. I mean, it still runs, but the state of the TV remains off all the time.

Was there any chance that may result in this behavior?

I restored my system to 2022.12 and it’s working as it should again.
There is definitely something in 2023.1 that is messing with it.

Running everything on the latest versions (2023.1.4) and the media card as-well as the mini are working as expected.

Have you checked your logs, is your TV still connected to your network and on the same IP etc, didn’t you change anything in your network lately?
For example enabled isolation on WiFi or LAN ports?

Same here, all running good

No, I did not change anything on my network.
As I mentioned, the moment I reverted it back to 2022.12, it started working again.

It also broke for me. The TV was actually correctly reported “On” just before the upgrade to 2023.1.4. It has not worked since the upgrade, always reporting the TV as “off”.

The TV’s network did not change, although it is on a different subnet than homeassistant. It had been working like that flawlessly until the upgrade.

I tried to remove the integration and add it again, but it fails. After submitting the pairing request, it just spits the following error: “Failed to connect, please turn on your TV or check ip address”.

I am sure I used the correct IP address. I also scanned for open ports with nmap and there are several ports open. Something must be broken in the 2023.1.4 release.

1 Like

I believe this is the problem:

and here is the fix:

So we will just have to wait it out until it gets released.

So there was a problem after all :slight_smile:

Thanks for the update, I’ll now wait for the new release with the fix.

I had the same problem till version 2023.1.4

Yesterday upgrade to 1.6 as the 1.5 and 1.6 have WebOS fixes but when i try to connect the TV again i get an “Unknown error” in the integration.

Logs show websocket error:

  File "/usr/local/lib/python3.10/site-packages/websockets/legacy/client.py", line 666, in __await_impl__
    await protocol.handshake(
  File "/usr/local/lib/python3.10/site-packages/websockets/legacy/client.py", line 332, in handshake
    raise InvalidStatusCode(status_code, response_headers)
websockets.exceptions.InvalidStatusCode: server rejected WebSocket connection: HTTP 200
Connected DDisconnectSDisable Autoscroll^KClear Console

Someone get the integration working again in 2023.1.6?