LG webOS Multiple TV configuration

Hi All,

I’m having some trouble configuring multiple LG webOS tv’s in my home assistant setup.

Official documentation states that these should be set out like this:

  - name: Living Room TV
    host: <ip>
  - name: Bedroom TV
    host: <ip>

However, this does not appear to work in my setup, I have the following:

  - name: Bedroom TV
    host: <ip>
      service: wake_on_lan.send_magic_packet
        mac: "<mac>"
  - name: Living Room TV
    host: <ip>
      service: wake_on_lan.send_magic_packet
        mac: "<mac>"

I’ve also tried the following::

  - platform: webostv

Which also didn’t work. I have also tried putting each pairing key into an individual file and using the "filename: " attribute, which didn’t work too. Those that have multiple webOS tv’s, what is your config like, and what works for you?

Do you get any errors in the logs or do you only see one of the tvs?


I get the following in the logs (the only error)

Logger: homeassistant.setup
Source: components/webostv/__init__.py:110
First occurred: 1:22:19 PM (1 occurrences)
Last logged: 1:22:19 PM

Error during setup of component webostv
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/setup.py", line 213, in _async_setup_component
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/webostv/__init__.py", line 99, in async_setup
    await asyncio.gather(*tasks)
  File "/usr/src/homeassistant/homeassistant/components/webostv/__init__.py", line 110, in async_setup_tv
    client = WebOsClient(host, config_file)
  File "/usr/local/lib/python3.8/site-packages/aiopylgtv/webos_client.py", line 67, in __init__
  File "/usr/local/lib/python3.8/site-packages/aiopylgtv/webos_client.py", line 94, in load_key_file
    key_dict = json.loads(raw_data)
  File "/usr/local/lib/python3.8/json/__init__.py", line 357, in loads
    return _default_decoder.decode(s)
  File "/usr/local/lib/python3.8/json/decoder.py", line 337, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/local/lib/python3.8/json/decoder.py", line 353, in raw_decode
    obj, end = self.scan_once(s, idx)
json.decoder.JSONDecodeError: Expecting ',' delimiter: line 1 column 55 (char 54)

Looks more like a problem with the integration.
Can you please try with only host and name?
Does it still work fine for a single tv?

Just taken it back to just the host and name and still getting the same error which is irritating.

I had this set up with a single TV just fine, since adding the second, that’s when these issues started.

If it’s an integration problem, would this need reinstalling?

Edit: felt I should mention, I’m running HA OS 5.6 & Supervisor 2020.12.7

I more think that it’s a bug in the integration, I’dfile a issue on github for this.
I can’t see any comma in your config or in the example condig in the docs but the error states that ot is expecting a comma, that’s why I assume it’s a bug in the code.

No worries, thanks!

1 Like