LG webOS Notifications w/icon: Problems

Hello all. I’ve got notifications working perfectly, with my webOS, however, when I try to add the icon: component, it fails. I’m using the exact example here:

    action:
      service: notify.livingroom_tv
      data:
        message: "Nicole Arrived Home"
        data:
          icon: "/local/nicole.png"

The notification simply won’t display on the TV when a picture is attempted to be used.

My install is Docker on the Synology and my image path is actually /config/www which I understand maps to the above /local/ space. This is certainly true for the other images I put in this location and they work fine.

I have also tried using a known-to-be-working in HA elsewhere image at that path with the same result.

I have tried .png and .jpg files. Does the webOS notification have any restriction on image size/type that I should be paying attention to?

1 Like

I’m having the same issue. The message only appear when I send it without an icon. :frowning:

My config:

- id: washer_finished_notification
  alias: Washer Finished Notification
  trigger:
    platform: state
    entity_id: binary_sensor.washer_status
    to: 'off'
  action:
    service: notify.livingroom_tv
    data:
      data:
        icon: www/images/washmachine1.png
      message: Washer has been finished!

My TV: webOS TV SK8550
Software version: 05.10.25

1 Like

Similar to the issue reported here.

Add your comments there, so someone may look at it.

I have same probem. Now WebOS not supported it? Anybody try to ask LG support?

Mine is working without the icon, but the message last only few seconds on the TV screen. I think the message must remain on the screen until the OK button is pressed on the remote.

yeah, same issue. Did you got any options to make the message hold on the screen ?

Not yet and I think it is a problem on the TV side, so the TV firmware must be modified accordingly.

I’m glad I found this topic, because I was struggling with the same ‘icon’ issue.

I can now show only message without icon…

Seems like this issue https://github.com/home-assistant/core/issues/31213 is again exist

No, it’s not bug. Messages on TV works OK. I think WebOS not support custom icons now.

Anybody else having this same issue