LG webOS TV - problem with wake_on_lan

Hello everyone, nice to meet you :wave:

I’m just getting started with home assistant, had no problem with getting my lights to work etc. but once I started configuring the TV things started to get weird. We got an LG webOS TV in the living room, which can be controlled without any problem except turning the TV on. The TV supports wake_on_lan, so I tried this rather simple automation:

# Switch on TV via LAN
wake_on_lan: # enables `wake_on_lan` integration

  alias: Fernseher einschalten
  description: Schaltet den Fernseher im Wohnzimmer ein
    - platform: device
      device_id: redacted
      domain: webostv
      type: webostv.turn_on
  condition: []
    - service: wake_on_lan.send_magic_packet
        mac: re:da:ct:ed
  mode: single

HA won’t let me save this, stating:

Message malformed: extra keys not allowed @ data[‘wake_on_lan’]

Any ideas on how to solve this? I tried to remove the data section from the action, still same issue. Sorry if this is a newbie question, hope you can still help me! Found a few threads on the forum and some github issues, but they unfortunately did not help

For everybody that comes here in the future: Indeed, I was a stupid newbie who did not read careful enough!

The line


does not belong into the automation file that you want to associate with the TV “on” button! It however belongs into the config/configuration.yaml file. You might want to install the file editor addon (or similar) to edit this. Afterwards restart home assistant.

Hi @Mornielome, I am still struggling, and hoping you will be able to help me out!

I followed all the documentation and the multiple topics on the issue, but once again it doesn’t work. Here is my code (in the automations.yaml file). I am running on Raspberry Pi, Docker container:

- id: '*************'
  alias: Turn On Living Room TV with WakeOnLan
  description: ''
  - platform: webostv.turn_on
    entity_id: media_player.lg_webos_smart_tv
  - service: wake_on_lan.send_magic_packet
      mac: "AA:BB:CC:DD:EE:FF"
      broadcast_address: ""

I can see the button to turn on the TV from the Off state, but it won’t actually turn it on. What am I doing wrong?

  • container is set up to work on the same network as the host

  • The TV is running LG WebOS 4.1.5

  • Connected on ethernet, confirmed broadcast address

  • LG Connect Apps enabled in Network Menu

  • Option for “Mobile On” does not exist in General Settings on the TV