LG WebOS TV Update on HA 0.104.0 not working

I updated my HASS.IO version this morning to the latest build and i noticed that there are a number of updates including how you interact with the LG WebOS platform.

I have made the changes that seem to be in the documentation but im getting a config error;

The following integrations and platforms could not be set up:

* [webostv](https://www.home-assistant.io/integrations/webostv)
* webostv.notify

Please check your config.

Now below is the code in my setup but i am not sure exactly what the issue is, as a note when i run the Check Config process it comes up with the following errors;

Invalid config for [webostv]: [filename] is an invalid option for [webostv]. Check: webostv->webostv->0->filename. (See /config/configuration.yaml, line 114). 
Platform error remote.webostv - No module named 'homeassistant.components.webostv.remote'
Platform error remote.webostv - No module named 'homeassistant.components.webostv.remote'

configuration.yaml

notify: !include configuration/notify/notify.yaml
webostv: !include configuration/webostv/webostv.yaml

notify.yaml

   # LG TV Notify
   - platform: webostv
     host: 192.168.1.92
     name: 'Living Room TV'
     filename: '/config/configuration/webostv/lr_webostv.conf'
     
   - platform: webostv
     host: 192.168.1.129
     name: 'Master Bedroom TV'
     filename: '/config/configuration/webostv/mb_webostv.conf'

webostv.yaml

  - host: 192.168.1.129
    name: 'Master Bedroom TV'
    host: 192.168.1.129
    filename: '/config/configuration/webostv/mb_webostv.conf'
    timeout: 5
    turn_on_action:
      service: wake_on_lan.send_magic_packet
      data:
        mac: 20:3D:BD:47:75:17
    customize:
      sources:
        - livetv
        - netflix
        - plex
        - youtube
        - otherbox 
    
  - host: 192.168.1.92
    name: 'Living Room TV'
    filename: '/config/configuration/webostv/lr_webostv.conf'
    timeout: 5
    turn_on_action:
      service: wake_on_lan.send_magic_packet
      data:
        mac: E8:F2:E2:3C:A7:5C
    customize:
      sources:
        - hdmi1
        - hdmi2
        - livetv
        - plex
        - youtube
        - netflix

Has anyone got any ideas what im doing wrong ?

Thanks in advance

1 Like

Same / Similar issue here.

Error during setup of component webostv
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/setup.py", line 170, in _async_setup_component
    hass, processed_config
  File "/usr/src/homeassistant/homeassistant/components/webostv/__init__.py", line 91, in async_setup
    tasks = [async_setup_tv(hass, config, conf) for conf in config[DOMAIN]]
KeyError: 'webostv'

Started right after the update to 0.104.0

Removed the following and rebooted and its now asking to configure the TVS again, at the office so will do that when i get home tonight see if thats it fixed;

    filename: '/config/configuration/webostv/mb_webostv.conf'
    timeout: 5

I have the notify to check also so will feed back.

1 Like

I adapted my configuration also to the documentation.
Apparently the filename: was also wrong in my case.
Same situation - system is now waiting for me to come home to to the pairing :slight_smile:

Will update as well

regards from Austria!

Same problem here, I too deleted the two lines and rebooted, but the errors persists, however, in my situation it did not spawn any prompts for reconfiguration. Fear something really broke with this component.

I had to overhaul my config.yaml as this was not as it should be according to the documentation.

This is how it looks now - however I could not verify the functionality (however at least it prompts for the pairing)

config.yaml

webostv:
  - host: 192.168.1.xxx
    name: TV
    turn_on_action:
      service: wake_on_lan.send_magic_packet
      data:
        mac: "xx:xx:xx:xx:xx:xx"
    customize:
      sources:
        - livetv
        - youtube
        - hdmi1
        - 'Amazon Prime Video'
        - 'Sky X'
notify:

media_player:
  - platform: webostv
    host: 192.168.1.xxx
    name: TV
2 Likes

Thanks.

Same here, somehow, it had gone passed me that this had become its own integration, I still had it configured as a media_player. All back working for me now.

1 Like

Is anyone else having trouble with the Wake On Lan feature and controlling their TV like volume and channels after updating to 0.104.0? I can only interact with it to turn it off if I have manually powered it on.

I followed the new config steps. Pre 0.104.0 I could use WOL and control it without issue.

Update, now I cant seem to interact with it at all. I will try restarting. I have gone through all of the TV settings, and the Home Assistant new configs. Early diagnosis is this new WebOS component may still be buggy, but if anyone can offer help, if they ran into the same issue and solved it, that would be greatly appreciated. I can update as I find out more

This worked for me!

if you have 2pcs tv then how to configure it

Hi!
I assume Andrew’s config should work in that case.
I haven’t tried - my config works for my one TV Setup

   # LG TV Notify
   - platform: webostv
     host: 192.168.1.xxx
     name: 'Living Room TV'
     
   - platform: webostv
     host: 192.168.1.xxx
     name: 'Master Bedroom TV'

I can’t get this to work at all, what is the domain? media_player? I tried webostv: but it didn’t work.

It should be under media_player.NAME
NAME is what you defined when you setup the webostv integration.

In your configuration remove the data under media player and notify for your webos tv that the previous integration required.

OK seen there has been a bit of a conversation in my absence but i have managed to link both my LG TVs, however there seems to be some strange behaviour.

When i first installed it i was prompted to configure both TVs which i did and it successfully connected, however every reboot of my HASS.IO device triggers another pairing request for the first TV i paired again suggesting that its only saving the conf file for the last device to be paired.

This in the past was dealt with by using the filename variable to specify a conf file for each TV, now that this option has been deprecated it appears to only save a conf file for one TV at a time.

Take that aside also i don’t seem to be able to get the notify function working or indeed be able to use the remote control buttons, this is something i a, going to look into today see if i can get to the bottom of it.

1 Like

I have 4 LG TVs and this missing filename isn’t an option for me… I can’t re-pair all of them every time.

I saw on another post that you can rebuild the webostv.conf

I only have 1 LG tv, so not sure if it works…

However, I seem to have another issue, it looks like my automation isn’t triggered properly:
the state: ‘media_player.living_room_tv’ doesn’t detect the state change from 'Off" to ‘*’

Did you see in the breaking changes that the on state is now called “on” instead of “playing”? Not sure if that’s your issue or not, but my automations are working properly after making this change.

Neh…tried from ‘Off’ to ‘On’ also…
( the original automation is from state ‘Off’ to *, so that should include ‘On’ right?)

Multiple TV’s are supposed to work with a single configuration file. This was broken in 0.104.0, but fixed in 0.104.1.

There are major changes in 0.104 both to the upstream library and in the webostv component to support the new features (input commands, non-polling state updates, etc), so it’s possible there are still some remaining bugs, or issues with certain TV models, etc. If you’re still having issues with 0.104.1 please open a github issue with detailed config and log info, etc.