Life 360 Unknown error

I’m getting an error when I try to add life 360 that says unknown error. I have tried it from the configuration.yaml file and i have tried it from the UI. Has anybody else had this issue? Below is the configuration i was using in the configuration.yaml file

    - username: LIFE360_USERNAME
      password: LIFE360_PASSWORD

Thanks in advance for the help!

Can you provide the exact error text? Where exactly do you see it? Anything useful in home-assistant.log?

Here is the error i get when i try to add it through the UI

When i try to add it through the configuration.yaml I don’t get any errors and it shows up in my integrations but when i click configure it just locks up and doesn’t do anything

Please set the logger to enable debug for life360 and homeassistant.components.life360 and try again. Then look in home-assistant.log for related messages. It’s even possible there is an uncaught exception, and if so, this should also show up in home-assistant.log (and probable the Info page in the frontend.)

Enabled the logger and saw this error

life360.exceptions.CommError: HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /v3/oauth2/token.json (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x72bf7bd0>: Failed to establish a new connection: [Errno -3] Try again')

I’m using a raspberry pi 3 with a static IP and using my DNS server as primary and google DNS as backup

So I reset my static IP using a usb drive and now it’s working! I can’t explain it cause I used the same IP and gateway I have been using. Maybe I fat fingered something when I did it the first time? Thank you for the help. The error log was a great help!

I can’t explain why it wasn’t able to reach the Life360 server, but that was definitely the problem. And the config flow code was deficient in handling this error case. I just submitted a PR to fix that so hopefully if this happens in the future it will be handled a bit more gracefully.

Awesome! Thank you!