LIFX and UDP errors

Hi a
Getting regular (~80% of restarts) errors with the LIFX platform. The error stops hassio booting at all, getting the following in the logs:

ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/aiolifx/", line 278, in try_sending
  File "uvloop/handles/udp.pyx", line 157, in uvloop.loop.UDPTransport.sendto
AttributeError: 'uvloop.loop.UDPTransport' object has no attribute '_address'

Tried adding server (being RPi IP address) in the lifx platform config with no success and going bit crazy!
Thanks for any help.

(Oh and if this is better in the Hassio forum let me know and I’ll move it)

I’m also getting this. Just updated the server to the latest build, it was working fine before. Did you manage to find a solution?

Hi, no solution sorry :frowning: For now have disabled my LiFX light and may just replace with Yeelight or something instead.

Hassio 0.81 provides an integration for LIFX that works fine for me now - remove the platform: lifx config and just configure the integration through Hassio instead.

Oooh, maybe hold on that. It did work but after a restart looks like same error again - and now as it’s not it in my config I don’t know how to undo it (Hassio won’t start so can’t get to Integrations!) . :expressionless: