LIFX component error after upgrade to 0.39 and now 0.40

Hi everyone… Thanks for the help in advance.

As stated, the LIFX component is not loading since the latest rounds of upgrades. I have tried rolling back to 0.37 to only find that it still fails to load.

It seems that there have been a couple of other threads that had the same problem with no resolution.

System: RPI3 w/RJLite
HASetup: All in one installer

Specific Config:

  - platform: lifx
    allow_unreachable: true


17-03-22 12:20:51 ERROR (MainThread) [homeassistant.components.light] Error while setting up platform lifx
Traceback (most recent call last):
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/helpers/", line 153, in _async_setup_platform
    entity_platform.schedule_add_entities, discovery_info
  File "/usr/lib/python3.4/asyncio/", line 388, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.4/asyncio/", line 286, in _wakeup
    value = future.result()
  File "/usr/lib/python3.4/asyncio/", line 277, in result
    raise self._exception
  File "/usr/lib/python3.4/concurrent/futures/", line 54, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/components/light/", line 52, in setup_platform
    lifx_library = LIFX(add_devices, server_addr, broadcast_addr)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/components/light/", line 74, in __init__
  File "/home/homeassistant/.homeassistant/deps/", line 100, in __init__
    self._sock.bind((listener_addr, UDP_PORT))
OSError: [Errno 98] Address already in use

I should also note that the following config doesn’t work:

  - platform: lifx
    allow_unreachable: true

Anyone have any insight that could possibly help?

Thanks again!

@austexas – What if you remove the allow_unreachable: true?

I have LIFX bulbs working fine with the AiO Fabric installer, here’s what’s in my config:

Alternatively, you could try out this PR.

Thanks, Brian. Removing the allow_unreachable doesn’t seem to work. I was unaware of that PR you referenced and will try that asap.

I will report my results here once I am done.

Thanks again!

@austexas – You could also try removing your liffylights from the config/deps folder and then allow it to re-install.

Well… reporting back without luck.

I created a cutom_components directory and a light directory inside of that at /home/homeassistant/.homeassistant

I then added the file inside the light directory.

After changing my config and rebooting, the lights are still not showing up. Here is the new log:

17-03-22 15:46:34 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/usr/lib/python3.4/asyncio/”, line 235, in _step
result = coro.send(value)
File “/usr/lib/python3.4/asyncio/”, line 679, in create_datagram_endpoint
raise exceptions[0]
File “/usr/lib/python3.4/asyncio/”, line 664, in create_datagram_endpoint
OSError: [Errno 98] Address already in use

I believe I am now moving backwards.

Thanks. I will try that next.

Sorry if this is a stupid question, but is there anything I need to do to re-install after removing liffylights? Or will it automatically install at reboot?