Lifx component options, and issues with Lifx bulbs

Hello !

I am trying to use HA to control my LIFX bulbs (Colour 1000).
Using the “lifx” component, I am unable to change the broadcast address.
Here is what I wrote in my configuration.yaml file:

    - platform: lifx
#      server:
#      broadcast:

I am using a Debian server to run the docker version of HA. My server is connect to both (wifi) and (wired) networks.
I tried with both networks, but the broadcast is always sent to (checked with wireshark). This is a problem because my default route goes through eth0, so on the network, from which the LIFX bulbs are not reachable.

However, I tried with the “lifx_legacy” component, and it works. So I’m wondering whether the documentation is up to date or not.

First issue solved :slight_smile:

My second issue is that when I configure Home Assistant with the “lifx_legacy” component, the bulbs don’t respond.
Here is my configuration:

    - platform: lifx_legacy

However, if I run the example script from this GitHub on my laptop, it works flawlessly.
I took a look at the network traffic with wireshark, and I don’t understand why the bulbs respond in one case and not in the other. is my Debian server is my laptop is one of my bulbs (I just filtered on this particular one, I tried with another one too)

Could someone point me in the right direction?

Thank you

Edit : after taking a closer look, I saw this:
Data sent from Home Assistant (lifx_legacy):
Data sent from the GitHub example script:

Is the “lifx_legacy” component using a different version of the protocol?
If so, how to make it work with the new “lifx” component in my case?

1 Like

I’m quite dumb, and didn’t notice my installation was outdated. I’m now in 0.54, and everything works fine with the standard “lifx” component.

1 Like