Lifx+ no infrared

Has anyone come across the problem where a Lifx+ A19 light is only recognised as a normal A19 colour (no infrared)?

The light came in black packaging and has the + icon on the light but no matter how many times I reset the light and re-join it to the network it shows up without the infrared ‘eye’ icon and without infrared brightness setting in the app.

I bought it at a local shop (Bunnings) so I exchanged the light yesterday. The replacement is doing exactly the same thing.

I dont think I have any control over the IR of my + bulbs, it does work though…

can you see it turn on ?

When using the Lifx app do you see these two settings circled in green?

They are not present when I connect my supposedly ‘+’ light.

Also I have tried to turn the infrared brightness to 100% using the dev tools services panel in HA (with the white/colour light off). Viewing the light with a 950nm sensitive camera shows nothing.

You should have control over the infrared brightness according to this: https://www.home-assistant.io/components/lifx/#service-lightlifx_set_state

infrared Automatic infrared level (0…255) when light brightness is low (for compatible bulbs).

My problem seems to be that this light is not showing up as an infrared compatible bulb in the Lifx app.

I got some Lifx+ BR30s. They connected no probs.

@CountParadox Try this, works for me (rename to suit your lights):

input_number

lifx_deck_ir:
  name: Deck Infrared
  initial: 0
  min: 0
  max: 255
  step: 1
  icon: mdi:track-light

automation

- id: deck_ir_brightness
  alias: 'Deck IR Brightness'
  initial_state: true
  hide_entity: true
  trigger:
  - platform: state
    entity_id: input_number.lifx_deck_ir
  action:
    service: light.lifx_set_state
    entity_id: light.lifx_deck_spot
    data_template:
      infrared: "{{ states('input_number.lifx_deck_ir') | int }}"

lovelace

type: entities
entities:
  - entity: light.lifx_deck_spot
    toggle: true
    type: 'custom:slider-entity-row'
  - entity: input_number.lifx_deck_ir
title: Deck Spot Light
show_header_toggle: false

@tom_l I’ve just bought a BR30+ and whilst I can control the IR setting in the app I can’t get it to work via home assistant. I have no idea if/when you’ll see me resurrecting an old post but am curious if the control is still working for you and if so what firmware you’re on?

My Device Info shows:
LIFX+ BR30
by LIFX

Firmware: 2.77

I’ve tried having the light on/off, with IR disabled/enabled via the Lifx app, and in all cases whilst the service doesn’t return an error I am not seeing the change reflected in the Lifx app as I’d expect.

It is still working for me. Unfortunately I have no way of checking the firmware as none of my lights are in the cloud and I will not be on my local network again until next year (home assistant does not include this as an attribute).

Just realised the firmware version is shown in the configuration / devices page. I’m using v2.77 for my lifx+ lights.