LIFX, VLANS, and Home Assistant

I currently have my Home Assistant server and LIFX bulbs on the same VLANs, but would like to split them out to something like:
Home Assistant: VLAN 2

I have a test Hass instance on VLAN 2 right now, but cannot get LIFX bulbs to show up. Here are a few things I have tried, including combinations of them:

  • Followed the Home Assistant LIFX page and set a broadcast address of xx.xx.xx.255 - I have tried using both VLAN’s subnets at different points
  • Setup the UDP Broadcast relay on my Edge Router for both VLANs with a port of 56700. (LINK for reference)
  • Added LOCAL firewall rules to each VLAN allow UDP destination port 56700. I see traffic on the stats page, but no bulbs in Hass.
  • Tried setting the Server flag for the LIFX component
  • I have Unifi access points and have confirmed that “Block LAN to WLAN Multicast and Broadcast Data” is not enabled (I have Chromecasts that work across VLANs with the MDNS repeater, so I know this is OK.

I’m at a loss right now on what else to try. Any thoughts or anyone else have a similar setup?

Late reply but hey, I was googling around for something loosely related

The main point of VLANs is to block broadcast and multicast. MDNS repeater service will work on Chromecasts but not on LIFX.

They just won’t see each other.

I think the lifx light component in hass now supports specifying IPs directly, check “Advanced Configuration” at

Specifying ip’s worked for me. My configuration file looks like this.

    - broadcast:
    - broadcast:
    - broadcast:
    - broadcast:
    - broadcast:
    - broadcast:

I’m in the middle of moving over my lifx lights so some are on my lan the others on my vlan. Luckily it works as long as you specify each bulb ip. Hope this helps someone who is struggling to get this to work as I was for the last few hours.


Long time ago but maybe I can get some help to the same problem:

I have same configuration – the problem is, I even can’t install LIFX integration because the installer doesn’t find LIFX components and setup is canceled therefore.
So I can’t go to Advanced Configuration as the LIFX Integration was not installed.

Is there any work around?

Need to add Lifx to the configuration.yaml file

1 Like

Sorry to drag up an old thread but I’ve just bought my first LIFX bulbs and tried adding them on a different VLAN (and subnet) from HA. I gave the bulbs fixed IP addresses in my router and then added those in config as below, however they don’t seem to show in HA other than a generic LIFX integration page with no entities.

    - server:
      port: 56700

(HA is at but I have other devices on the same 192.168.30.x VLAN / subnet which work fine)


An tips as to what I can do to get these bulbs working?

Funnily enough I had the exact same problem yesterday. It worked for me if I only included the broadcast as part of the config

    - broadcast: <IP address of LIFX bulb>

Thanks. I went into the config to make that change and realised I had a typo in the IP address the whole time. Once I fixed that it worked. I just have to get a second bulb to join my wifi now, for some reason it keeps failing. Any tips on that? I’ve tried about 10 times now even on different wifi SSID’s / VLAN’s.

It won’t even join via the LIFX app? That seems odd, maybe check there’s no typo’s in the wifi password either :stuck_out_tongue_winking_eye: Otherwise I only have one LIFX bulb so can’t help you much haha

I did some Googling and the fix was to force close the LIFX app, clear the cache and try again. Finally got the second bulb connected. :+1:

Late reply, but I had the exact same issue with Lifx bulbs being on a different VLAN. I add this configuration and a restart fixed the problem. I didnt have to setup UDP broadcast on my UDM Pro

LifX - VLAN 3

    - broadcast: