Light Group All entities missing

Hello to all,
I would like to put an automation in place to notify me if any light in my home is “unavailable” or “unknown”. For this reason, i wanted to create a group of all lights and when it’s state is unknown or unavailable it would trigger the automation. Reading the documentation i found the following:

Binary sensor, light, and switch groups allow you set the “All entities” option. When enabled, the group behavior is inverted, and all members of the group have to be on for the group to turn on as well. A complete overview of how groups behave when the “All entities” option is enabled:

  • The group state is unavailable if all group members are unavailable.
  • Otherwise, the group state is unknown if at least one group member is unknown or unavailable.
  • Otherwise, the group state is off if at least one group member is off.
  • Otherwise, the group state is on.

However, when i try to create the group in HA i don’t have the “All Entities” option. Is this a bug? Can it be done via YAML, and if yes, what do i need to add to the groups.yaml file?

Sharing a screenshot of a light group in the UI:


Replying to my own post… You need to create the helper and edit it after it was created for the option to appear. Please consider this solved, however, it is not clearly visible from the beginning and a change would be much appreciated.


I’ve the issue…
I’ve edited after creation but still not seeing the option.
Do I miss something?
As option is there a way to play with yaml code?

Thank you!

Strange, it should be there:

I am also missing this option - running on latest stable docker instance.
My use-case is that I want to combine lights ‘vertically’ - I have a KNX-controlled switch light with Zigbee bulbs on the end of that power line.

I’m also seeing the same issue (no “all entities” option visible).

I’m having the same issue, running the latest 2023.9 version.

1 Like

The same thing happened to me.

Home Assistant OS 10.5


On your screenshot i believe you show the group during creation. Please try to create it first and then edit it. The option should be there after creating it for the first time.

I’m also having the same issue here, docker deployment latest:latest - iirc can check.

Option is mentioned by the dialogue but not visible in the edit screen. Tried on both Edge and Firefox.

Checked on the app too, all entities is not visible there either after creation.

Same Issue:

  • Core 2023.11.3
  • Supervisor 2023.11.6
  • Operating System11.1
  • Frontend 20231030.2

I had the same issue and found the answer here:

Basically, you need to enable “advanced mode” for your profile.


Thank you @rolrha It works as expected now.

Thanks, it solved it for me on 2024.1.0.
Although i dont quite understand the reason of advance mode for this…