Light Groups no entity available

I created some light groups in my config.yaml file, but tried to move these to their own file. I made one named light.yaml and moved the light groups to this one. But now I get entity now available in my dashboard. When I had one of the light groups in the config.yaml file everything worked file. I can’t figure out how to get the light groups linked from the light.yaml file.

This is my light.yaml file.

- platform: group
  name: All Lights
    - light.hue_color_lamp_dinning_room
    - light.hue_color_lamp_1
    - light.hue_color_lamp_3
- platform: group
  name: Living Room Lights
    - light.hue_color_lamp_1
    - light.hue_color_lamp_3


How have you linked to it in your configuration.yaml file?

Like this?

light: !include light.yaml

Yes, I have it linked in the congif.yaml file, like this.

# Configure a default setup of Home Assistant (frontend, api, etc)

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene:  !include scenes.yaml
light:  !include light.yaml

And you don’t have light: at the top of your light.yaml file (you shouldn’t)?

And you restarted Home Assistant after moving the lights to the file?

1 Like

Ok, so I did another restart and that seemed to work, everything is back in my dashboard now.

Thank you.

1 Like