Light.mqtt and RGBW value. how to set 'W'

looking at this integration: light.mqtt

i have a couple lights on my zwave network on zwave2mqtt, which then show up in HA as a mqtt device.

on the zwave side, i have one RGB controller which only gives me the RGBW setting to adjust the light
image in a #RRGGBBWW format

so i have no “seperate” W channel, just the W that is part of this variable.

in HA, we define a light, type mqtt, and we can define an rgb_value_template, but the rgb control only has red, greed, and blue variables built in.
the mqtt.light does have a white channel option, but no way i can see to get that into the rgb_command_template.

IS there any way to add a white value to the rgb command, or some other way to make this work?

  "rgb_command_template": "{{ \"#%02x%02x%02x\" | format(red, green, blue)}}",
    "rgb_command_topic": "homeassistant/77/51/1/0/set",
    "rgb_state_topic": "homeassistant/77/51/1/0",
    "rgb_value_template": "{{ value_json.value[1:3] | int(0, 16) }},{{ value_json.value[3:5] | int(0, 16) }},{{ value_json.value[5:7] | int(0, 16) }}",

I’m interested in this as well. Did you manage to figure it out?

Currently, because the RGB and W are seperate commands, they override eachother. If I used the colorpicker to pick an RGB color, the white channel is turned off. When I then use the white channel slider, it turns off the RGB. I’d like to use them all together.