Light.turn_on not working correctly (brightness) - Conbee / Ikea Tradfri GU10


I’m running and i’ve gotten Ikea Tradfri GU10 spots around the house. In the hallway I have a set of 6 GU10’s. About 5 meters away from the Conbee in the raspberry.

How the setup works is: I have a motion sensor and that is linked to an automation that turns on the lights using the automation below:

alias: Bijkeuken Verlichting Aan
description: ''
  - type: motion
    platform: device
    device_id: 97cfb1ac67389471f9377bac83d55ff8
    entity_id: binary_sensor.motion_sensor_bijkeuken
    domain: binary_sensor
condition: []
  - service: light.turn_on
      brightness_pct: 100
        - 3fd4945608279443bb0160fc6f70aadc
        - 89d9dc2f5b2db33d3086149b69346195
        - 593fa480b6c2a0a36b8fe4689cd82f0c
        - 7b547cb71f87a7d5ea2260c6180e015d
        - 63d819d589b4d0c03e117a8b40f134af
        - 9c110a6f306a66fce738fe32ab67a7f8
mode: single

The issue that I am facing is that either the light does not turn on, or the light does turn on but to the lowest brightness setting. This is not the case every thing, so some times it works find, and another time it does not work. It’s not the same light too, it’s a diffirent light.

I’ve never had it occur that a light does not work off. So the light.turn_off works 100% of the time.

So I can’t find the exact cause, but I did notice that this issue is only since the last few updates of Home Assistant. A few version back this was not an issue.

I’ve tried putting the lights in a single group, and using the group to control the lights. But that does not change the behavior.

Looking in DEConz I see a good and strong mesh connection between all the lights, so that is not an issue.

For example; when I notice a light that does not work as intended, if I manually run the automation again: it works fine.

Thanks for the time!

Try grouping the lights in deconz and them use the new entity that will be created in your automation.

Currently you are sending the command to 6 lights at the same time, this means 6 commands will be sent to your conbee and from there to the individual bulbs. This can lead to delayed or even lost commands. However, if you group the lights and use the grouped light, only one command will be sent and it will automagically be propagated to the individual bulbs.

Thanks! Indeed, i’ve grouped all the lights in ‘Groups’ in Deconz / Phoscon and now it works as intended. I’ve also traced the commands, now HASS sends 1 command to the "Deconz Group’ and that works perfectly.

In my old scenario, HASS has a group of 6 or 8 lights, and those send 8 commands to Deconz.