Light.turn_on turns light off

EDIT: A firmware update popped up and after many failed attempts, I moved the device right next to my Skyconnect and it updated after like a 3 hr wait. Now, the device is not behaving like light.turn_on is light.toggle anymore. Woohoo!

Using a ThirdReality Zigbee Night Light.

I have the following service activate when motion is detected, however if the light is already on, the light will be turned off instead which is not the behavior I want. So every time motion is detected, the light toggles on/off. Is there any way around this? Note that in Home Assistant the device still shows it is on, however it actually gets turned off. I have no local-to-the-device actions enabled, so it strictly operates via HA.

service: light.turn_on
metadata: {}
color_name: red
brightness_pct: 50
entity_id: light.indicator_light

Normally I would suggest checking if the light is already on before attempting to turn it on. However you said the following so its actual state isn’t certain.

It appears the device doesn’t report its actual state when it’s changed.

Yeah, and what I’m not understanding too is that if I can manually change the light color while it remains on, then why can’t that happen in an automation? How is HA doing it when I use a slider or color preset, and is it possible to replicate that?



It actually remained on as well.