Lights not turning on, when using a manual switch if they are off in HA

Hello all! I am fairly new to Home assistant, I believe I have set up everything correct. For now my setup mostly consist of lights, will be adding new stuff later on, but we have just moved and there is a lot of things to do :smiley:

So my problem is as following, I have set up an automation to turn off all the lights in the evening. All of the lights are connected to an physical normal “dumb” light switch that cuts power to the lights if turned off. The plan is of course to have an automation to turn them on again in the morning, I just didnt have time to set it up at the same time. But this led med to finding this strange behavior:

If the lights are set to off in HA and I try to turn the manual light switch off and then on again, the lights do not turn on again (few times, they have). At our old house, we only had a few ikea trådfri bubs, and I used an ikea hub/gateway. But even if the lights were off in the ikea/homekit we could ALWAYS turn the manual switch off, and then on again to turn on the lights again.

So is this something weird in HA? Did I configure something wrong? Are the lights not supposed to turn on when I turn the light switch off and than on again?

My setup consists of some ikea trådfri bulbs and some phillips hue bulbs. Further I have an older PC I use as a server, where I have installed proxmox, and run an vm with home assistant OS on. For my “hub” I use an conbee 2 stick, with deconz addon to HA.

Assuming when the physical mechanical switch is turned on, you can correctly turn the lights on and off via home assistant then I would suspect that this is related to the power restore setting of the bulbs themselves.

Some bulbs will revert to previous state, some will stay off and some will switch on when physical power is restored - with most sensible smart bulbs you should be able to set this behavoiur.

I am not sure what the bulbs are you have and how you have them paired to HA but I suspect its caused by the power restore settings of the bulbs.

From the zigbee2mqtt.io docs, it looks like most ikea bulbs have a power on behavior setting.

In ZHA, you’d probably have to poke around under the Manage Clusters dialog for the device and see if you can find an appropriate setting.

There is a long thread here somewhere on Hue power on behavior that might yield some insights.

Thanks for suggestions! All the hue bulbs are GU10 white ambient, and one e14 color ambient all with bluetooth. All of the hue bulbs were new, but sat in the sockets and acted as dumb bulbs until I got around to installing and configuring the HA server. But in order to connect them to my conbee stick I had to pair them with bluetooth to my hue app on the phone, and reset them to factory settings. At least now with your suggestions I have something to go on!

After a little bit of digging, it may have found the problem. The power on behavior was set to on. However, in Phoscon I had added lights to groups. And in HA I set an automation to turn off the group. When the whole group was turned off, the lights would not revert to the on state when the switch was turned off and then on. When I removed a bulb from the group in Phoscon, the manual switch worked like a charm…