Lightwave configuration

Trying to get my home assistant to pair with my Gen 1 lightwave.

Got the configuration files set up but need to pair the lightwave hub - tried the commands
ncat -ul 9761 &
echo -n “123,!F*p” | ncat -u -v IPADDRESS 9760

but ncat and nectar are not found, nor is sudo or apt… so I’m unclear what shell tools are available that will allow me to pair the hub.

And when paired, is there a simple way to know what the mapping from lights to their references is? I have 15 of them in the kitchen alone, so trial and error will take a while…

ADDENDA: home assistant is running on a NUC under Proxmox via the GitHub install.

Sorry I can’t help you with what you are looking to do as I am brand new to HA running on a Raspberry Pi but I will follow your thread with interest as I have 34 Gen 1 devices I’d like to pull into HA but the more I read about it the more confused I get! :confused:

I would be interested in what you have done so far with your config files if they would apply to RPi as well…

Thanks & kind regards,

I’ll happily help once I get it sorted! Config - no Lightwave devices show up yet, so nothing to help you - as for working o the Pi, it’s the same version and so on so all solutions will work fine. Note I used to run on a Pi3 but the crashing SD cards and slowness means £100 was well spent on eBay for an i3 NUC and vastly greater speed and reliability.

Great…thanks xcentric.

Well I currently have 4x Pi 4 Model B 4GB running PoE headless with one hosting Pi-hole, the second feeding 4 Virtual Radar sites, another Pi given over exclusively to HA and a ‘hot spare’ with a bare bones OS being kept up to date should I lose one or think of something else to run! Like a Stratum 1 NTP Server as I do have a GPS/RTC HAT kicking around somewhere… :crazy_face:

They are in colour coded aluminium cases but I really should invest in a cluster case of some type I suppose.

Hopefully no reason to spend money on other machines at the moment but I will keep an open mind although to be honest I have far too many computers running here as it is! :grimacing:

I know I shouldn’t tempt fate as I haven’t yet corrupted a MicroSD Card but as a safeguard I regularly clone my system card to a ‘hot spare’ I keep in an adaptor in a USB 3 port on each Pi just prior to doing any major updates or installing packages so I’m as comfortable as I can be running Pi’s for this type of task at the moment.

Hopefully some kind & knowledgeable soul will be along soon to give us both the answers we need.

Kind regards,

Never managed to resolve this either.

My experience with Lightwave was not good, but I stuck with it having invested so much in switches and sockets. Tried a Gen 2 hub in the hope that it might make things simpler (it didn’t). In the end I went on ebay and spent about £10 on one of the remote controllers that went with the original Gen 1 kit. These can pair with up to 16 switches.

I used the remote to “teach” the commands to a Broadlink RM4 Pro and the result is a huge improvement: much more reliable and no longer Internet dependent. Both hubs have been relegated to the attic.

Well I decided to have a bash at the Gen 1 LWRF integration today and happy to say I think I’ve cracked it…on my setup at least! :+1:

My configuration.yaml looks like this;

# LightwaveRF      
  host: Your_LWRF_Link_IP_Address_Goes _Here!
      name: Bedroom
      name: Bedroom Reading Lamp
      name: Hall
      name: Kitchen
      name: Landing
      name: Living Room
      name: Living Room Uplighter
      name: Living Room Reading Lamp
      name: Office
      name: Storeroom
      name: Front Bedroom
      name: Bathroom
      name: Toilet
      name: Larder
      name: Immersion Heater
      name: Arcade Table
      name: Cabinet
      name: Christmas Tree
      name: Ultraviolet
      name: Christmas Lights
      name: Sky Q
      name: Curtains
      name: Headphones
      name: Outside Back
      name: Outside Front
      name: Outside Icicle
      name: Outside Side
      name: Extractor
      name: Socket
      name: Shed
      name: Heater
      name: Fan
      name: Compressor

It took me a while to sort out the Room ID/Device ID as I had never used Wireshark before to sniff the packets filtered by my LW Link IP Address as I stepped through them one by one using the LWRF App to toggle each device on or off in turn but it all seemed logical in the end even for me!

I suppose you could get by with trial & error by not using Wireshark and just adding an entry for Room 1 Device 1 and call it Test in the yaml or something as the logic is the devices are grouped by Room so if you have two light switches and a socket in the room it could be that they are identified as R1 D1, R1 D2, R1 D3 etc.

Adding one entry at a time and then renaming Test to the actual device name when you have identified it is a long-winded way of doing it but you only have to do this once.

Rooms seem to be arranged in the order that they were setup in the LWRF app as are the devices.

Around 2011 the first room I installed an LWRF dimmer was in my bedroom so that became R1 D1. The next device in that same room regardless of whether I installed a dimmer, relay, socket or plug in another room before adding that second device in the bedroom became R1 D2 and so on.

The next room I setup became R2 and the first device was D1 and continued using this pattern over the years.

I also found out that although some of my devices such as Outside Lights which are controlled by the 821 relay would not work when added under lights; in the yaml as the command from the LWRF Link is different from the dimmers so they had to be entered under the switches; section even though they control lights and I have them labelled as lights.

Hope that helps?

Thanks & kind regards,