LightwaveRF connect issues

First generation lightwave hub and switches.

Running on virtual machine on intel nuc.

Set up the yaml file, but can’t seem to pair the hub - turn the switches on and off in the overview and press the hub button, but nothing happening.

Can’t send the netcat or nc commands to the hub directly as others have, as nectar isn’t installed in the system and so there’s no way of teaming the hub there’s a pairing request.

Rebooted lightwave hub, checked the configuration.yaml file. Flicked the switches on and off a lot whilst pressing and releasing the hub button - nothing…

Has anyone solved this?

Update: by switching to the sh shell I could run the echo command - but nothing still from the hub. Press it to pair it, but no control from HA.

Deleted all devices and rooms in the app - didn’t quite expect it to delete all from the server too so now have to reconfigure and see if I can get it to work.

Will just try one light first…

so, paired up 4 light switches in one room (kitchen).
Rewrote yaml file to just contain those lights, and added dummy switch as it sometimes seems to need that.

Still won’t pair - tried HA dashboard switching, then pressing pair button, and sending echo command - nothing. Have the lightwave hub on a different vlan to the HA one, but as I can ping it, it shouldn’t be an issue. Any ideas anyone?


the given syntax of

echo -ne "100,\!F*p." | -u -w1 YOUR_LIGHTWAVE_HUB_IP 9760

doesn’t work for sh - removing the " gives

echo -ne 100,\!F*p. | -u -w1 9760

which then worked…

now to add back in all my lights…

I also have LightwaveRF first generation lights and switches - and found an alternative approach which does away with the hub altogether.

When the first generation devices originally appeared there was a 433.92MHz RF remote control which could be paired with up to 16 switches (JSJSLW106) - they’re still easy to find on Ebay for £10-£15. If you get one of these and pair it with your switches, you can then use it to “teach” the on/off commands to a universal controller like the Broadlink RM4 Pro. I found the range of the Broadlink was easily enough to cover the whole house. You can then use Broadlink command codes to create switches in HA.

Hello - I’m having issues pairing. Wondered if you could share what you did?

I’ve put the lightwave code into the YAML file and added two devices (I just guessed that they would be R1D1 and R1D2)

I’ve tried running variations of echo -ne 100,!Fp. | -u -w1 9760* from the Terminal, but get various errors like:

➜  ~ echo -ne "100,!F*p." | nc -u 9760
zsh: event not found: F
➜  ~ echo -ne '100,!F*p.' | -nc -u 9760
zsh: command not found: -nc
➜  ~ echo -ne '100,!F*p.' | -u 9760 
zsh: command not found: -u
➜  ~ echo -ne ‘100,!F*p.’ | nc -u 9760
zsh: event not found: F
➜  ~ echo -ne 100,\!F*p. | -u -w1 9760
zsh: no matches found: 100,!F*p.
zsh: command not found: -u`Preformatted text`

I’d be extremely grateful for guidance.
I’m totally new to HA