LightwaveRF error

Hi can anyone help having problems with built-in lightwave RF, keep getting these errors

2018-12-18 18:47:45 ERROR (Thread-4) [lightwave.lightwave] [Errno -2] Name does not resolve
2018-12-18 18:47:56 ERROR (Thread-5) [lightwave.lightwave] [Errno -2] Name does not resolve
2018-12-18 18:48:49 ERROR (Thread-6) [lightwave.lightwave] [Errno -2] Name does not resolve
2018-12-18 18:48:54 ERROR (Thread-7) [lightwave.lightwave] [Errno -2] Name does not resolve
2018-12-18 18:50:47 ERROR (Thread-8) [lightwave.lightwave] [Errno -2] Name does not resolve
2018-12-18 18:50:59 ERROR (Thread-9) [lightwave.lightwave] [Errno -2] Name does not resolve
2018-12-18 19:20:52 ERROR (Thread-10) [lightwave.lightwave] [Errno -2] Name does not resolve
2018-12-18 19:20:58 ERROR (Thread-11) [lightwave.lightwave] [Errno -2] Name does not resolve

My configurations yaml is as follows

   host: ""
       name: Wall lights
       name: Ceiling lights
       name: Tree socket
       name: Radio socket
       name: Light socket
       name: Phone socket
       name: Torch socket`

Now getting error

2018-12-19 19:11:24 ERROR (Thread-14) [lightwave.lightwave] LW broker timeout!

In the example at
there are no quotes around the IP address.
Also - you show 000 at the end. If that is what you really have there then it is not right.

I have tried it without and with quotations,without gives me the ERROR [lightwave.lightwave] LW broker timeout!.

According to the document that I linked to … “host” is an IP address.
So you should not have https:// at the front of it.
Also, if you have 000 at the end then that is also incorrect.

Thanks Paul,I have removed https & i’m using the correct ip address, but the error is sill the same.I am using a control unit with the LCD which i think is V1, could this be the problem?

This probably needs assistance from someone who has one of these Lightwave devices … but … were you watching the device to see if it asked for confirmation?
Also - probably worth posting the current version of your config again.

@Andy_Nunes did you get this sorted? I have the same issue.

Same issue here also

No unfortunately not still having the same problem:(

Did anyone work this out?

I recognise this may be too late for you, as the was opened a while ago. But it may help others.

Host should just be the IP, no prefix as the communication is via UDP

   host: 192.168.0.xx

(Modify IP as appropriate).

You will also the need to make sure the HA host is registered with Lightwave…

ncat -ul 9761 &
echo -n “123,\!F*p” | ncat -u -v 192.168.0.xx 9760


  • If this says not registered, press the button on the lightwave with 12 seconds of the command.
  • If this say OK, then you are registered, and this is not the issue.
  • If it says anything else, it’s probably a networking error.

Keep retrying until you see OK. It won’t work until it’s registered.

1 Like


I’ve got the same issue but I don’t know where and how to enter the commands to register the HA host with Lightwave. Please can you explain?


I am using Home Assistant Core, so run the command on the underlying Linux operating system.

Not sure how it would work in using the Home Assistant Operating System.
I think if you restart HA, then try to change a thermostat value, the first time you try it will attempt to register, so you have 12 seconds to press the button on the Lightwave box.

Thanks Colin, I tried that but still no joy. I have since found out that the lightwave hub is recognised under the homekit integration and when I decided to give it a go, it worked so I’m using that.

I ran into the same issue myself, as I just swithed from HA Core in a Python Venv, to running HA OS.
So, I’ve re-written the HA lightwave integration code not to need a proxy.
Been running OK in my setup for a week now.
Just tidying the code, and will start submitting pull requests into HA…

Here the start of the direct integration, with no proxy.

Library update: Integrate UDP Listener, removing need for Proxy by ColinRobbins · Pull Request #8 · GeoffAtHome/lightwave · GitHub

HA updated branch: GitHub - ColinRobbins/Home-Assistant-Core at lightwave
Will create PR once library update agreed).