Home Assistant Community

Limit IP from which HA can be accessed

#1

A long time ago I have somehow added a list of ip ranges from which my home assistant instance (via Duck DNS) can be accessed. Now at work the ip ranges have changed, but I can’t find back where to add the new ranges… Can anyone assist? I’m running Hass.io on a raspberry pi with just regular port forwarding on my router.

#2
#3

I only have this:

  auth_providers:
   - type: homeassistant

Not sure if in an old setup I had the trusted networks…

#4

It changed in v0.89. It used to be under http:

#5

Thanks for looking into this with me.
I have trawled through all backup files, but have not found any use of trusted_networks.
Besides, if it is not in the current config, why would that still be limiting me?

#6

Maybe it was in the firewall of your router?

#7

Nope, nothing there…
Starting to think it may be the network at work that is limiting the access, but any other suggestions still very welcome…

#8

Could be. My work has just implemented a new proxy and firewall that prevents me accessing HA because all dynamic DNS services are blocked. Might have to switch over to Nabu cassa.

#9

But when else to tinker with Home Assistant than during the boss’s hours? :laughing:
I’ll have to check from another location then…

#10

So Tom… look at the ZeroTier One addon - that will def work in your work. As you’re with ABB, you can also use IPv6 with HA. In actual fact I only use IPv6 - my HA NUC does not update duckdns with a IPv4 address at all. Plenty of things you can do/use for remote access…

#11

I tried the ZeroTier One addon . I got my phone and HA online with it (according to the zt1 dashboard) but cant ping either one from the other (using the zt ipv4 addresses). Unable to connect with the ios app using the zt1 ipv4 address (http or https).

It’s easier just to turn off my phone wifi at work and use the cellular network. Work pays for the phone plan so… :man_shrugging:

#12

I couldn’t get it to connect on initial release either but lates updates work - so not sure when you tried. Yeah I can’t / don’t use it with the iOS app…

#13

I just tried to visit my duckDNS address to get the exact firewall message to pass on to our security team for the possibility of adding an exception and…Dynamic DNS sites are unblocked again today.