Limitlessled cant control lights with HA

so Ive been trying to get this working for three days. i have a mi light bridge v6 and a few lamp in one zone i can control the lamps with my phone via the app no problem but i’m unable to do so via ha, i’ve tried so many different configs but nothing works this is the one i’m running now. has any one an idea of what i’m doing wrong, the ip is right and i can ping towards it as well

  platform: limitlessled
  - host:
    version: 6
    port: 8899
      - number: 1
        name: BedroomLights
        type: rgbww

this is the error i’m getting but i get none the wiser out of it:

2019-11-16 21:04:38 ERROR (MainThread) [homeassistant.components.light] Error while setting up platform limitlessled
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/limitlessled/group/commands/”, line 25, in command_set_factory
cls = next(cs for cs in command_sets if

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/”, line 150, in _async_setup_platform
await asyncio.wait_for(asyncio.shield(task), SLOW_SETUP_MAX_WAIT)
File “/usr/local/lib/python3.7/asyncio/”, line 442, in wait_for
return fut.result()
File “/usr/local/lib/python3.7/concurrent/futures/”, line 57, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/src/homeassistant/homeassistant/components/limitlessled/”, line 158, in setup_platform
group_conf.get(CONF_TYPE, DEFAULT_LED_TYPE),
File “/usr/local/lib/python3.7/site-packages/limitlessled/”, line 155, in add_group
group = group_factory(self, number, name, led_type)
File “/usr/local/lib/python3.7/site-packages/limitlessled/”, line 47, in group_factory
return RgbwwGroup(bridge, number, name)
File “/usr/local/lib/python3.7/site-packages/limitlessled/group/”, line 25, in init
super().init(bridge, number, name, RGBWW)
File “/usr/local/lib/python3.7/site-packages/limitlessled/group/”, line 57, in init
self._command_set = command_set_factory(bridge, number, led_type)
File “/usr/local/lib/python3.7/site-packages/limitlessled/group/commands/”, line 30, in command_set_factory
raise ValueError('There is no command set for ’
ValueError: There is no command set for specified bridge version and led type.

Looking at the docs, port is 8899 for versions less than 6. You have specified version 6 so the port might be 5987. I have no experience with this integration, so I am guessing from the docs.


Bridge version.

Default value:



Bridge port. For older bridges than v6 choose 8899.

Default value:


You could always run nmap to check which ports are open

@nickrout is right. You have the wrong port. Here is my config.

# LimitlessLED
- platform: limitlessled
    - host: !secret limitlessledhost
      version: 6
      port: 5987
      - number: 1
        type: rgbww
        name: Lounge
      - number: 2
        type: rgbww
        name: Dining
      - number: 3
        type: rgbww
        name: Office
      - number: 4
        type: rgbww
        name: Desk
# Office Light Group
- platform: group
  name: Office Light Group
    - light.desk

@nickrout i have indeed also tried that port and have chanced it again in the bridge aswell, but no luck.
@DavidFW1960 I have taken over you config, but no luck either

but can it be that there is nothing behind that port i have let nmap run on that port but its closed and only finds something on port 80 tcp. these are the settings in the bridge it self

- platform: limitlessled
    - host:
      version: 6
      port: 5987
      - number: 1
        type: rgbww
        name: bedroom light

The error you show is from mixing version 5 with rgbww.

You can leave out version and port since the defaults work with your bridge. Do not change anything in the bridge UI, it works with factory settings.

The bridge is talking UDP so you will not be able to nmap the port.

Are you sure they are rgbww?

@DavidFW1960 well they don’t specially say that, i just assumed it because they are rgb +cct

My ones specify they are rgbww on the box they came in. Sounds like yours aren’t.

Not true, nmap can scan udp addresses.

My bad, I phrased that poorly.

If you have RGB+CCT (adjustable white temperature), it is indeed type rgbww. Adjusting the temperature needs two different white LEDs to mix and this is what WW means here.

This is a bit confusing because rgbw (i.e. constant white temperature) comes in CW/WW editions, meaning cold or warm white but not both.

Anyway, the error you have shown is an invalid configuration issue, combining pre-v6 bridge with rgbww. It should not happen with the configurations that you have shown in this thread.

If you get the same error no matter what you do, maybe you are editing the wrong place?

@amelchio well after resetting the bridge about 4 or 5 times I finally got them working how ever only with the rgbw type setting in the config. but they work now and im able to control them, so may be they aren’t rgbww after all ?!

The bulb capabilities can also depend on the virtual remote that you use to pair within the smartphone app.

Be sure to use one that can control white temperature, such as this FUT092.

1 Like

@amelchio okay clearly its my first time using this, i dint know that makes a difference to the lights, i relinked the lights whit that virtual remote you linked and now the rgbww works. fail on my part

Oh, that’s good to hear. Don’t feel bad, the MiLight stuff is quite strange (but it works well within its limits).