Linear NGDZ00-4 Garage Door

That is correct. Never got involved with it. Started straight off with umbuntu and HA in a VENV.

Of course I had an old (but not too old) computer sitting around which made it a pretty easy choice for me.

Well, my NGDZ00-4 just died, after maybe 1 year of service. The door sensor works fine, it detects open and closed, but if you open/close it via z-wave it beeps like normal, but there is no flashing strobe nor does the door open or close. So now’s it just an overpriced garage door sensor.

Go look on Amazon and sort by newest reviews, and marvel at the number of one star reviews for the exact same problem. Clearly a design defect. If compiling a custom open-zwave hasn’t scared you away and you’re still considering buying this, I would think twice.

At least now I can probably go back to the release version of OpenZwave and not worry about maintaining my own custom build anymore. :grimacing:

Any suggestions for replacements?

As I just had one fail on me as well, I started looking on fleebay and discovered that there are a number of different firmware and hardware versions. The newer ones are sold under the GoControl brand with rev.B hardware and 2.1FW and are zwave plus. My older iris version is rev.A with 1.0FW and I have a Linear with Rev.A HW and 1.2FW. The Linear one is the one that failed. I might try the zwave plus version

I’m sure you’ve done this, but I once had a similiar problem. Had to unplug and plug back in, and it started working again. Also if the connector to the opener comes lose, evertything you’ve described could happen. The zwave device does not know if the electrical pulse was received or not

Though this is true, it was for me a precursor to total failure of the device. When it starts requiring a power cycle and a wake to get to work again… 2 months later it would be unresponsive and report wrong status.

@rafale77 and others, if you are a tinker you might look at Open Garage

I am pulling my hair out with this lol. I have tried every combination I can think of and can’t get anything more than sensors. I also can not get 1.5 to show up in my ozw_log.txt, no mattter what I try I get: OpenZwave Version 1.4.2926 Starting Up

The Setup:
Ubuntu and Docker Compose

I’ve tried:

FROM homeassistant/home-assistant:latest

RUN echo "Removing old python-openzwave"
RUN pip3 uninstall -y python-openzwave

RUN echo "Installing latest version of cython"
RUN pip3 install --upgrade cython==0.24.1

RUN echo "Installing dev python-openzwave"
RUN pip3 install --no-cache-dir python_openzwave==0.4.3 --install-option="--flavor=ozwdev"

I have also tried:

RUN set -e && \
    apt update && \
    apt install -y unzip && \
    wget -O /tmp/ && \
    cd /tmp && \
    unzip /tmp/ && \
    cp -R /tmp/open-zwave-1.5/config/* /usr/local/lib/python3.6/site-packages/python_openzwave/ozw_config/ && \
    rm -rf /tmp/ /tmp/open-zwave-1.5 && \
    apt remove -y unzip && \
    rm -rf /var/cache/apt/*

I have tried secure adding in OZWCP, in Homeassistant, I’ve tried 0.4.4, 0.4.3, 0.4.3 ozwdev, 0.4.4 ozwdev, 0.4.9, and no matter what it’s always sensors!


Probably a dumb question but did you add this to your configuration.yaml, but I will say that the sensors should not show unknown. Definitely add secure.

  platform: zwave
1 Like

If I add everything in OZWCP it shows the full name, not unknown, adding through HA shows unknown. Still can’t figure out why 1.5 won’t show either.

I’m not running docker, but I rememeber that if you update to dev flavor, and dont make a change to one of the HA config files, that it will change back. Here is some info from where I had the same issue earlier in this thread. Maybe this will help.


Based on the latest code on github they’re updating HA python_openzwave requirements to 0.4.9 so anyone using the dev version will want to do this before the next update:

pip3 install --no-cache-dir python_openzwave==0.4.9 --install-option="--flavor=ozwdev"

1 Like

Are you using @hawk259 's instructions from his post?

1 Like

Is the requirements_all.txt file on github? I looked last night but couldn’t find it. Granted it was about 4am and I was frustrated so I might not have looked well.

@ptdalen I updated 2 files at one point:

RUN echo "Editing the file"
RUN sed -i s/python_openzwave==0.4.3/python_openzwave==0.4.9/ /usr/src/app/homeassistant/components/zwave/

RUN echo "Editing the homeassistant requirements_all.txt file"
RUN sed -i s/python_openzwave==0.4.3/python_openzwave==0.4.9/ /usr/src/app/requirements_all.txt

Do I need to specify the dev version in the edits as well? or is just the version number fine?

Line 38 on the file gives it away :wink:

Yes you need the flavor option to get barrier support.

Also note, after I updated my nodes were renamed I had to go back and name them via HA. Instead of it adding _state_label it just comes up like this example: garage_door_state I had to rework a few automations due to this :roll_eyes:

FROM homeassistant/home-assistant:0.75.3

RUN set -e && \
    pip3 uninstall -y python-openzwave && \
    pip3 install --upgrade cython==0.24.1 && \
    pip3 install --no-cache-dir 'python_openzwave==0.4.9' --install-option="--flavor=ozwdev"

I assume this didn’t work for you per hawk’s post?

0.75.3 still use 0.4.3. It will be upgraded in the next release.

I just built my docker image yesterday and it is working great.

Any other changes in the new version of openzwave? Would be cool if it had native support for the opener, but alas I doubt it does. haha

0.4.3 -> 0.4.9 in the next release is just python_openzwave, it is still using the dev version of openzwave.

Until openzwave 1.6 is released (I think 1.5 is dev), we have to patch 1.4 or use dev version (1.5). No way around it.


Assuming you did the below code:

FROM homeassistant/home-assistant:0.75.3
RUN set -e && \
    pip3 uninstall -y python-openzwave && \
    pip3 install --upgrade cython==0.24.1 && \
    pip3 install --no-cache-dir 'python_openzwave==0.4.9' --install-option="--flavor=ozwdev"
  1. Did you also modify another file to prevent HA from changing versions?

  2. Do I need to remove and re-add the node?

  3. Anything else in your config besides:

    platform: zwave (i know the spacing isn’t YAML compliant, can’t figure that out on this forum)