Linear NGDZ00-4 Garage Door

I am trying to get the above device working now we have support for ZWave Garage doors - previously I had it working through MQTT and my Smart Things Hub.

I can add it to the ZWave network and OZWCP sees it and reports it as a SecureBarrierAddon (I had to patch OpenZWave to add support for it), but HA doesn;t seem to recognise it - I don’t see any new device types. Can anyone give me a hint please?


barrier operator command class is currently not supported

Ok, thanks for the confirmation.

Womp :frowning: Didn’t realize this was a problem until I tried to set this up. My guess is my options are to buy something like a SmartHub or Vera and then associate that to Home Asistant? Does the Aero garage door opener work well through Home Assistant instead?

For the curious, as of this writing, I tried this on the dev branch as well and it would appear that barrier operation is not available there either.

I have it working via a Smart Things hub and MQTT bridge, but its the single last thing to migrate before I can turn my Smart Things off forever!


I ended up buying an Iris GDO, which appears to be this exact same model. Does anyone know of any openers that will currently work?

I use a 2gig panel via and did notice that recognizes it as a Garage Door Opener (even with the 2gig panel as a secondary controller), but I haven’t had any success with it seeming to work. I don’t have the thing hooked up to the actual door opener though. When you issue an open/close command it’s supposed to beep numerous times to alert folks to the fact and I can’t get it to do that in isolated testing.

Z-Wave Garage Door support was apparently a lot more of a recent addition to HA than I thought (it seems to have appeared in 0.23) so perhaps it is a feature forthcoming. When fiddling with things in the Open ZWave Control Panel, I do see messages relating to barrier operation but OZCP isn’t sure what to do with those things either.

It’s not worth it to me to buy an off the shelf controller just to use my garage door in this way so if I can’t get it working, I’ll just return it and perhaps try the Aeon Labs opener (assuming it doesn’t require barriers).

I’m willing to ditch my ZWave opener and get another if it won’t soon work with HA - I see some chat in the Dev repositories about support for Chamberlain myQ, but have no idea if/when that work will be completed. In the meantime I’d also like to know what openers actually currently work.

I’d love to see this supported as well. I’ve made some progress adding it as a secure device, but I’m only seeing sensors, not switches. Will post here if/when I have full success.


That’s about as far as I got. I believe the secure component is more communication between devices so it didn’t seem like it affected Home Assistant much. The manual called for binding it securely but I actually did it both ways and was still able to see the sensors oddly.

For, it sees it as a garage door, but the open/close commands don’t work. I’m not sure if that’s because the 2gig panel is a secondary controller or not. I think in the short term I may have to return it and just buy it again once it is supported, or there is a known working compatible opener for HA.

So, I just got this working using OZWCP, but there is not a switch for me to actually be able to control it from within HA, as others said above. However, I do not think it will be difficult to do, and I’ll help with the code if possible. Pretty cool just to be able to open and close it remotely even without HA :slight_smile:

I see that others above have already gotten this working, but if anyone is stumpted, this is basically what I did:

  1. First you have to patch OZW and OZWCP to support the Barrier class. If you are not familiar with github or compiling/linking, I would strongly suggest that you go ahead and do some learning. It’s worth it, as most major open source software is on github and knowing how to clone repositories and build from source is almost a requirement with this kind of thing. I took this commit and patched the most recent master of OZW.
  2. I took this commit and patched OZWCP.
    2b. For kicks, I rebuilt and reinstalled python-openzwave as well.
  3. After successfully running OZWCP with the newly patched OZW library, I had to try twice to securely include the GD00Z-4 and got it to securely include (I would guess so anyway, as it’s working). I’m a new user on this community so I can’t post another link, but this may prove helpful:
  4. I’m not certain that the tilt sensor that’s placed on the door needs to be on and active or not, but I would go ahead and put it on the wall, ensuring that the little button is depressed on the back so that it is recognized by the GD00Z-4. Otherwise, you can simply depress the button, and make sure that you see something like this in your ozwcp:
  5. If you tilt the sensor to simulate an open and closed garage door, you should see the value at “Open” change between On and Off.
  6. To test that things should work as expected, I would recommend at this point hooking up a multimeter to test for conductivity and connect it to the two leads coming from the GD00Z-4. To test it, change the Open value from Off->On or On->Off. After the device beeps for 5 seconds, you should see a brief spike on your multimeter, indicating that the circuit was briefly closed and this is what gives your garage door opener the command to open/close.
  7. If this is working, it’s just a matter of testing with the garage door opener and mounting. I mounted mine on the hardware that the opener is mounted on. One of each of the leads from the GD00Z-4 goes where the wires coming from your current opener go. I have a Genie ReliaG 850 (2028), and there are four wires connected. The two on the left are for the safe-t-beam and can stay in place. The wires from the GD00Z-4 go into the two slots on the right. There is no polariy, unlike the existing wires that are there, which can remain in place.
  8. Activate as above using the Open On/Off toggle in ozwcp and after the beeping, the door should open/close.

Now, we just have to get it working in HA!


Oh wow that gives me hope! Thanks for the explanation! I’ll give this a go! Curious, are you able to run both OZWCP and HA at the same time? I find that I can’t run both using my Aeon USB stick. HA seems to grab an exclusive hold over the USB stick. It’s normally not a big deal but if I want to control the garage door using OZWCP and use HA, it’s a bit of an issue.

I haven’t dug deep into the ZWave bits of HA but I want to do so soonish. My current goals code-wise is to figure out how to better support the Radio Thermostat CT80.

Not very much I wouldn’t think - my CT100s worked pretty much out of the box.

It has to do with the radiotherm library. It doesn’t have definitions for the current CT80 revision so it bombs out. Adding the definition fixes that, which there’s now a few PRs for with the library (mine from last week and one from January), but the maintainer seems to have dropped off the radar. That’s problem 1.

Problem 2 is feature-set. I haven’t figured it if/how you can do things like “resume schedule” via HASS since it seems easier to do scheduling on the thermostats and then have HASS change it on certain events (like leaving the house). Double true for when HASS isn’t running (I’ve been making my fileserver fall over due to unrelated issues lately which of course breaks our automation). Likewise, the CT80 can report humidity, so "'m trying to figure out if that’s being logged in HASS and, if so, how to get to it. If not, how to add it in (radiotherm already supports pulling that data). I don’t have humidifier/dehumidifier stuff but the CT80 supports those as well and that might be nice to have in HASS.

Ahh, I see. Well good luck!

1 Like

I have one of the Linear openers waiting in my mailbox, so this will likely be my weekend project and a reason to get immersed in Python. Sounds like half the battle is getting the opener paired via some other means (I planned on using domoticz).

@m00dawg I don’t think you can run hass and ozwcp at the same time …

If hass doesn’t have support even with ozw supporting it (which it does, when patched), then I may just turn to an arduino-based solution, using a relay for open/close and a reed switch for status, with mqtt for event notification. It’s so much simpler than z-wave (the protocol I mean), and can be done wired, which is always a plus.

I think if I ended up going that route, I’d probably use XBee 900MHz since I’m already using that for outdoor sensors (with Arduino) but yeah I thought about something similar. Z-Wave is nice because I can focus more on the actual automation (I have plenty of hardware projects to keep me busy). From what I’ve read, the downside of the DIY route is the whole beeping thing the Linear does before it open/closes the door - that’s by code so you might want to implement something similar?

From what I’ve read, the downside of the DIY route is the whole beeping thing the Linear does before it open/closes the door - that’s by code so you might want to implement something similar?

Not quite sure what you mean – at the motor itself (or the switch on the wall), if you short the two wires, the unit opens/closes. So it’s as simple as using a relay to do that and using some means of “flipping the switch” – one option is a network interface using mqtt (light) or http (heavier); another would be a physical switch, if you didn’t already have one. I think the beeping is just to warn anyone nearby that it’s been activated, and that the door is about to open or close.

Right, the warning is what I thought I read was code. It’s because you can open/close the unit unattended. A normal garage door remote is basically line of sight, but with automation, you could do it anywhere so you wouldn’t see if, say, someone was standing there. Modern openers at least have those sensors (and I think crush sensors) so it’s perhaps unnecessary. I mean I wouldn’t worry about it unless you wanted to sell your house and include your DIY opener with it.

And, to be fair, I could have totally read all that stuff about building code and beeps totally wrong :stuck_out_tongue: