Linkind zigbee alarm starter pack

@Elle, I will be unable to give hands on help with this, because I don’t have the Hub in hand for a while. But if you haven’t updated the firmware of the Hub, then you should be able to log in to the OpenWRT with the password listed in the opening post of that discussion. If you have updated the firmware of the Hub, then you will need to contact one of the guys in the discussion, that how was managed to enable dropbear to access again the OpenWRT.
I am unsure that the uBoot has been locked or not, that could have been some other communication issue.
For triggering the siren, you can try first the command listed in the discussion’s end somewhere, and you can build some automation to run commands on the device from HA, so anything is possible.

1 Like

I never turned on the hub, I bought the kit just for the keypad :sweat_smile:.
I will try to follow the discussion :grinning_face_with_smiling_eyes:
Really thanks for your help.

1 Like

Then you should be good. Plug in the Hub, connect to the Wifi network what it creates. (I use a mobile phone most of the time.) Use Fing (app) to check the devices on the Wifi network. Check what ports the device has open, if 80 is open, then navigate to the IP address of the device and use root as username, and the password mentioned in the discussion. To connect to your own Wifi network, just set it up with the OpenWRT what is on it.

Personally I disabled the Linkind services on the Hub to do not “call to home”.

Good luck! Please report back how you proceed. Especially with the default password, as I never tried that.

1 Like

Hi, I’ve been able to connect to the Siren and command it! but I did not understand how I can deactivate the linkind services and make the siren work with my home wifi. could you help me?
attached the image of what I can see once connected to the siren.

Sorry for the late reply. I cannot really help with the full answer, because I don’t have access at the moment to the Hub to guide you through.

You should find the menu, where it lists the installed and running services. You need to disable the Linkind ones. Unfortunately, as I don’t have access to the Hub, I cannot give a full list.

But these are as I can read from this Github repo:

  • device
  • eagent
  • lagent
  • lds-keyring
  • ota
  • security
  • smart
  • subdevice
  • zipgateway
  • zware

To join your Wifi network, you need to bring up the Wifi settings, turn on the Wifi connection and connect the device to your local Wifi network, save the settings and then disable the Linkind AP.

Here is a generic OpenWRT instruction how to connect to Wifi networks:

Once you connected it to your Wifi network, check connection to other device with ping, etc. Then disable the AP. Save settings and then restart a few times. If you did it correctly all 3 LED lights should be green and you should be able to access the Hub from your network, and the AP will not be active anymore.
If the Wifi fails to work, then just power cycle, if it is still not working after, then reset the Hub and do it again. I struggled a bit until I managed to connect it to the my Wifi.

Thanks for your suggestions :slight_smile:
I’ve been able to find the list of services (going to the web interface, cliccking on system and selecting startup) and disabled the Linkind services (I hope so, but in any case at least the otap one is for sure disabled) then I tried to connect to my home network but I’m unable to do it, in the menu wifi I didn’t find the network and when I click on scan it give me back a blank page.
Do you know what I’m doing wrong in trying to connect the siren to my home wifi?

Edit the Client (Leedarson) add there your WiFi setting.

As I can remember the Hub can connect only to 2.4GHz WiFi networks. So if your Home WiFi is 5GHz one only, then you will have no luck.

1 Like

It works perfectly :slight_smile: Now I’ve just to understand how to command the siren from home assistant. Thanks for your help!

I hope this going to help enough!

Can someone please explain this in laymans terms Linkind ZS130000078 control via MQTT | Zigbee2MQTT

I’m new to home assistant and I don’t know what it means by payload etc. I have got it linked in Z2mqtt, but I obviously have the error it mentions in the general section, so I need to do the initialize after parting, but I don’t understand it…


I honestly can’t get this keypad working, I’ve been trying for several hours but the instructions on Zigbee2mqtt website make no sense, nothing is in plain, step by step English. It’s all assumptions that you know what you are doing.

Focusing on the keypad only, not the siren everyone is talking about in this thread - how do you send payloads and what do I do to get it configured correctly?

Tried this following the terrible instructions and it doesn’t do jack

Maybe you should start first with reading this:

Why do you post a question and a few hours later you do post the same question again, in a topic where people not actually talking about your problem, but you are assuming that someone will reply, because they have to, instead you would spend a bit more time and do some more searching and reading???

What do you assume from us? Without really knowing what you were doing with your device, we will tell you where things went wrong for you?

If you would have done a bit more search or just read the whole topic, you would have see my previous answer above:

But as I can see, you have a tendency to comment in all similar topics the same thing over and over again, until someone gives you an answer… Maybe take more time just to read things instead of spamming the whole forum with comments like these:

Me too mate, doesn’t work for me

This doesn’t work for me and Spotify integration is still broken af

Keep It Tidy

Make the effort to put things in the right place, so that we can spend more time discussing and less cleaning up. So:

  • Don’t start a topic in the wrong category.
  • Don’t cross-post the same thing in multiple topics.
  • Don’t post no-content replies.
  • Don’t divert a topic by changing it midstream.
  • Don’t sign your posts — every post has your profile information attached to it.

Rather than posting “+1” or “Agreed”, use the Like button. Rather than taking an existing topic in a radically different direction, use Reply as a Linked Topic.

Otherwise, please mind your language.


I gave your post a like, as you make fair comments. Apologies, I was very frustrated, but you are correct.

You may try to send the MQTT topic without the leading “/” - The documentation says:

Thank you. I’ve tried without the / and it still doesn’t successfully send the payload to properly initialize it.

I’ve added some scripts you can put on the Siren Hub in the comment here that turn it into a Wifi MQTT connected siren that shows up automatically in HA through MQTT discovery: Linkind Siren Hub · Discussion #796 · zigpy/zigpy · GitHub
This doesn’t use any of the “hub” features, it just makes it a basic Wifi-connected Siren.
Just make sure you disable all of the auto-update features before you connect it to the internet for the first time.


Does the Linkind Alarm Keypad expose the alarm code that has been entered?

I’ve checked the documentation on Z2M but I not getting a clear answer. May be it’s phrased in a way I’m missing?

Looking to bring this Keypad into Alarmo and have unique alarm codes per user.

Yes, it does. The MQTT message published has the typed code, that’s how the blueprint and any automation is working with it.

The codes are not stored in the device. HA reacts on the published MQTT message.

It will be in sensor.keypad_action_code or the related attribute Action code as I remember.

Anyone here knows an address where to buy this? I cannot find anything on Aliexpress, Amazon or other (international) sites. Preferable my country (netherlands) or else in Europe. Thanks!

They were being sold on eBay UK. But stock looks limited.