Linking 3 switches to a fan

Hey all!

I have 3 tuya wifi switches that I’ve made to wirelessly control a fan’s speed. If they’re all off, the fan is off, if the first one is on, then the fan turns on at the lowest speed, the second one turns on the medium speed and the third, obviously, the fastest speed.

I have it all in 4 automations… but my automations page is getting crowded…

Is there any EASY way to achieve the same functionality WITHOUT leaving home assistant (I’m looking at you node red fans) and in a simple way this non programmer can understand?

Thanks in advance people!

I use the GE switch. This is the Zwave 500 series, though I still have the 300 series, waiting for the 700 or 800 series to come out.
Last week I tried the new Inovelli Zigbee fan control switches, but I was unable to make these work other than ON or OFF. I returned these to Inovelli.

I’m not in the States… lol! :sweat_smile:

Besides, I’ve already got the switches installed and working… just looking for a cleaner solution…

Yeah, these switches are for the the US.
Using 3 switches for low, medium and high is indeed not a perfect solution.

To help we need to know exactly what geography you are in. As you noted devices vary by region.

And I’d be pulling all of those and replacing it with one fan controller.

1 Like

It’s the only solution I had then… :sweat_smile:

show your automation, easier to get suggestions then.

I’m in Spain… pulling them out isn’t an option…

This is a software issue… :sweat_smile:

Con todo respeto… you really should be looking for a hardware solution.

1 Like

This is one of the automations that controls the speed:

alias: Fan 1
description: “”

  • platform: device
    type: turned_on
    device_id: b261b22736f55dc03caef247c5752f67
    entity_id: switch.fan_1
    domain: switch
  • service: fan.set_percentage
    percentage: 33
    device_id: a433f13aac82b3ccda68b90b4168d8df
  • type: turn_off
    device_id: 893d26c912b1ed4a8472dce9312f9ee1
    entity_id: switch.fan_2
    domain: switch
  • type: turn_off
    device_id: 893d26c912b1ed4a8472dce9312f9ee1
    entity_id: switch.fan_3
    domain: switch
    mode: single

Lol! Thanks for the effort, but seriously, that isn’t an option atm…

Format it correctly, use the </> button. You could try tidying it up by using trigger ids:

1 Like

Nearly exactly what I need! Good enough until I reform the house and get around to a proper fan controller…


1 Like