Linking Haas Cameras to Frigate on a different server via Go2rtc - Help needed!

Hi there.
I have a strange problem and my most powerful Google Fu has uncovered zero leads… Maybe you can help?

The problem…

  • I have Home Assistant running on a HA Green.
  • I have my Nest doorbell all linked up nicely to Home Assistant.
  • I would like to set up Frigate on my Unraid server to record the feed from the doorbell.

I got Frigate working using the config tips from this post.

When I fire up Frigate it can’t get the camera stream…

…but if I click on the stream it shows nicely.

The logs say…

2024-05-29 20:16:48.333781917  [2024-05-29 20:16:48]                    INFO    : Camera processor started for front_door: 313
2024-05-29 20:16:48.335138913  [2024-05-29 20:16:48]                    INFO    : Capture process started for front_door: 315
2024-05-29 20:16:48.359674390  [2024-05-29 20:16:48]                  ERROR   : front_door: Unable to read frames from ffmpeg process.
2024-05-29 20:16:48.359860082  [2024-05-29 20:16:48]                  ERROR   : front_door: ffmpeg process is not running. exiting capture thread...
2024-05-29 20:17:01.639749997  [2024-05-29 20:17:01] frigate.comms.dispatcher       INFO    : Turning off recordings for front_door
2024-05-29 20:17:08.373469144  [2024-05-29 20:17:08] watchdog.front_door            ERROR   : Ffmpeg process crashed unexpectedly for front_door.
2024-05-29 20:17:08.373498883  [2024-05-29 20:17:08] watchdog.front_door            ERROR   : The following ffmpeg logs include the last 100 lines prior to exit.
2024-05-29 20:17:08.373584102  [2024-05-29 20:17:08] ffmpeg.front_door.detect       ERROR   : [tcp @ 0x55d37575d100] Connection to tcp://MyHomeAsssitantIP:MyHomeAssistantPort?timeout=5000000 failed: Connection refused
2024-05-29 20:17:08.373655095  [2024-05-29 20:17:08] ffmpeg.front_door.detect       ERROR   : rtsp:// Connection refused
2024-05-29 20:17:08.384933383  [2024-05-29 20:17:08]                  ERROR   : front_door: Unable to read frames from ffmpeg process.
2024-05-29 20:17:08.385090370  [2024-05-29 20:17:08]                  ERROR   : front_door: ffmpeg process is not running. exiting capture thread...

My Frigate config looks like this…

  enabled: False

    config: "//MyHomeAssistantIP/config"  # skip this setting if you Hass Add-on user
    front_door_frigate: hass://MyHomeAssistantIP:MyHomeAssistantPort?entity_id=camera.the_front_door&token=MyHomeAssisstantToken
      - MyUnraidIP:8555
      - stun:8555
    enabled: True
        record: preset-record-generic-audio-aac
        - path: rtsp://MyHomeAssistantIP:8554/front_door_frigate?video=all&audio=all
          input_args: preset-rtsp-restream
            - record
            - detect
      stream_name: front_door_frigate
      width: 960 
      height: 1280
      enabled: False # <---- disable detection until you have a working camera feed
      enabled: True
        days: 3
        mode: all
          default: 30
          mode: motion

Any ideas what I might be doing wrong?
Does the path to the Haas config look OK? Do I even need it?
(All the examples have Haas on the same machine as Frigate).

Thanks in advance for your help!

Well heck - I literally just solved it as soon as I posted this.
All I had to do was change line with the IP for Home Assistant to the IP for Frigate.
Looks like there must have been an error in that original post.
Oh well. It;s sorted now!