Little Z-Wave configuration question

Hello everyone,

I have a short question. I have a Z-Wave Network with 40 devices (Fibaro Walli Roller Shutter, Aeontec devices and so on). Now I want to install Fibaro Walli Switches and Fibaro Walli Dimmer for my lights:

On the other site I also want to use some Zigbee devcies. I have 14 Hue lamps (at the moment connected to my hue brigde) but for testing a connected 3 lamps to my conbee 2. My plan is to connect all hue lamps to the conbee 2. I also want to use some aqara devices in my house and here is were my question begins :slight_smile:

We have a lot of concrete walls and the conbee 2 is not able to communicate with the aqara devices in the next room or upstairs. So I connected the Hue lamps to the conbee 2 and the mesh network was able to connect to the aqara devices, but when the switch for the lamps is turned off, the connection is broken again. My first plan was to install Fibaro switches because I thought that when I press the button on the switch, the power is not interrupted and the Hue lamps continue to work as repeaters. Unfortunately, the Fibaro switches also turn off the power. Now the question is, is there a better solution than the Fibaro switches, or can I set the Fibaro switches so that when I press the switch that only a scene is triggered, which dims the lamps in the room to 0 percent.

Sorry for the long explanation…but I hope this makes the problem understandable.

In short, I want the Hue lamps to always work as repeaters even when the switch in the room is pressed. The option to completely remove the switches and make them “blind” is out of the question for me…

Thanks for your help

Great questions. I’ve run into the same thing, except with a slightly different goal: I have in-wall switches that turn off the power to smart bulbs on purpose. This means that even if HA goes down I can still control the lights from the switch, but the smart bulbs can still change the color temperature.

The effect is the same as what you are observing: each time I turn off the switch I lose devices from the Zigbee network. This is a real problem as one room has 14 GU10s, so a huge potion of the Zigbee mesh goes away, meaning that most Zigbee devices can’t communicate for ~5 minutes afterwards until the mesh is rebuilt.

To solve this I setup two Zigbee networks using ZHA and Deconz. The Deconz network has no switch-controlled devices, so its mesh is always good. All remotes go on this network. The ZHA network has all the devices that change color temperature, but if that is delayed by 5 minutes while the mesh rebuilds it’s okay.

This works almost perfectly. The problem I have is interference on the two Zigbee networks.

If you want to take this route, I have two suggestions:

  • Consider using Zigbee2MQTT as I believe it should support two Zigbee networks in one add-on. (Having both ZHA and Deconz works fine, but is annoying from a management point of view. I suspect using a hue bridge and ZHA/Deconz would also be fine.)
  • Remember that both networks need enough devices to build the mesh to all devices. So even if you have 10 devices from one network in a room, that doesn’t help the other network.
  • Start out with the two networks on different channels to avoid interference.


P.S. You might want to rename this thread to “Problems with Zigbee bulbs attached to Z-wave in-wall switches” or something so it is easier to find!