Live camera stream as a card on lovelace - is this possible?

indeed a few weeks ago it was available on HACS, but i think because this custom card was updated 2 years ago it’s blacklisted

Black listing happens from the author.
I remember reading about it when he first created the “card” and saying it was only a temporary work around because people kept asking for it. So I am pretty sure he/she is no longer maintaining it and asked for it to be black listed.
But I use it every day and it works great for my needs :slight_smile:

is there any alternative ? i used this card daily

I don’t know. I use this card daily as well :frowning:

i’ve got this error :frowning:

So @niemyjski says it’s fixed ,but this card is still blacklisted ( HASC) ? so what’s the next step to de-list this ?

I may be able to do another pr to get it removed from the blacklist. I’ll try today.

Well, the documentation in HACS to blacklist the repository says " To add a repository to the blacklist, open an issue here hacs/default repository"

So my quest is that you need to open another issue in the same sport to have it removed.

I am pretty sure @ludeeus “created” HACS so he would probably be the best to ask…

HI @kkellner take a look to my yesterday replay in another post,

Change streaming channels or low streaming resolution

This is my code for LOVELACE Card. I´m getting 2/3 seconds delay

aspect_ratio: 92%
camera_view: live
entity: camera.camara_frente
name: Camara Frente
show_name: true
show_state: false
type: picture-entity

Let me know if it works


I have several (13) Amcrest cameras. In 3 of them, all IP2M-841’s, the video live stream is very delayed, sometimes by as much as 2-3 minutes. Restarting home assistant syncs it again, but not for long. I’ve found no way around this and I’ve tried everything I can think of. The custom-cards/ **surveillance-card**card shows the live stream on those cams with NO buffer, but that card isn’t how I want to use the cameras.

Home assistant is definitely buffering the stream somewhere as the Amcrest app shows the actual live feed.

Has anyone found a solution to this annoying issue?


Anyone? Any ideas?

Did you tried my solution?

How did you config the cameras?

I actually already use the sub steam. I tried that long ago. Even reduced the frame rate. No difference on these cams. The delay can be as much as 10 minutes!!! Wtf… this HAS to be something in the camera subsystem in home assistant. I don’t have a memory card in any of the cams.

Very frustrating.


And streaming quality? I mean, did you change sub stream configuration to lower frame and quality?

How did you configured cameras like as generic or ffmpeg?

In Lovelace did you congfured as live, camera_view: live?

They are all the same… the ones that aren’t buffering, and the ones that are.

All set as follows:
camera_view: live

- host:
   name: outside
   resolution: low
   scan_interval: 5
   username: admin
   password: !secret amcrest 
   stream_source: rtsp
 - host:
   name: inside
   resolution: low
   scan_interval: 5
   username: admin
   password: !secret amcrest 
   stream_source: rtsp

There is a live view possible. You just have to change from a blueiris subscription to a free zoneminder one. I have live views working without a hitch for years now.

Works like a charm

1 Like

So many things can go wrong with these setups, but I thought I’d just add that the eureka moment for getting my camera entities to show up in Lovelace was making sure the stream it was using was encoding in H.264 instead of H.265.

1 Like

There’s also the WebRTC custom component which has a card that can stream video. WebRTC should (in theory) be lower-latency than HLS: