.local names not resolving from HASS

I’m running Home Assistant in a Hyper-V VM with a bridged network setting. Based on my testing here’s what I’ve observed:

http://homeassistant:8123 # Works fine
http://homeassistant.lan:8123 # Also works fine
http://homeassistant.local:8123 # Doesn’t work

All of my esphome devices work with all three methods though.

But unfortunately when I go into esphome in the Home Assistant UI all of my devices show up as “offline”, because it’s trying to access them on the .local address which it doesn’t seem to understand.

How can I either:

A. Make home assistant understand .local DNS names
B. Switch it to use the .lan names instead for esphome

In the ESPHome addon configuration turn on the “status_use_ping” switch. This may be under unused settings.

I found the answer, you can switch it to use .lan in your config:

  • domain (Optional, string): Set the domain of the node hostname used for uploading. For example, if it’s set to .local, all uploads will be sent to <HOSTNAME>.local. Defaults to .local.

Thanks @tom_l - that did the trick to make the device show as “online”