Local realtime person detection for RTSP cameras

I am mounting an NFS drive and passing it as an argument to docker with -v /mynfsdir:/media/frigate argument. It works mostly - but a couple of time frigate.db got corrupted when stopping frigate. I had to delete the db and restart (which worked for the most part except lost history of clips). I wish there was a separate directory for database vs media.

Problem will be probably somewhere else because this link works for me:


The only difference is in “after” instead of “before” for camera name.

Hi, I just installed it and I’m testing uses with a coral usb (I think the last in stock in europe).

I have a very stupid question: how can I delete clips and records from testing recognitions?

To answer my own question:
As some people already mentioned, it is very important to use the actual dimensions of the video input. for example my camera says it records in 640x360 but it is actually in 640x352 (confirmed with VLC snapshot). After adjusting this, the substream is working flawlessly.
For the Reolink E1 Pro it is now working with the following configuration:

  • Detect on RTSP substream (minimal delay < 3 sec) with max. 7 FPS and no input_arguments for ffmepg
  • Clips on RTSP main stream with 4 MP resolution and 20 FPS
  • Hardware: Raspberry Pi 3b - no coral tpu (yet)
1 Like

Try frigate.yml

    type: cpu

I have 10cameras, with CPU with this settings and everything is fine.
Did you pass through the GPU to the VM? If you have intel you can pass the integrated graphic otherwise you will lost display.

Regarding LXC
Did you try this?

Btw after you will success you will have a problem that you can’t connect frigate to the hass GUI. Which will be useless if you wanted to use frigate inside the HASS like me.
Otherwise th LXC will have it own IP as i understand and you will connect directly to frigate.
Didn’t solved it yet

Yeah, for now i am not able to sort it out, i was writing to several threats.
One pointer is here, but don’t have time now.

That itst possiblee to mount the share before/after container is load. So you can change the media folder for NAS. When/If i will succeed will definetly write there as i see it is the only option. I’m surprised that nobody can just say how to do it rightaway

Evening All, I’ve got a couple of questions regarding frigate:

  1. Is possible to have cameras store files in subfolders? -
    1b) then maybe subfolders for clips and snapshots?
    1c) Is it possible to change the variables for the file name? what are the random letters and numbers at the end of the file name?

  2. A couple of my cameras only stream in h265, and I seem to be unable (tried in edge, chrome and vivaldi) to playback in the browser, I have to navigate and find the files which play without a problem in VLC - is there a way of fixing this?

  3. Is is possible to save the audio stream as well as the video stream?

  4. is it possible to display the 16:9 full stream on the home page, rather than 4:3 of the lower stream, or just force it to display in 16:9 aspect?

I know it’s a lot of questions, but i would really appreciate any help.

It is baby

  path: /config/frigate.db

Please can you explain how did you pass the argument? where did you and how changed it? Please i am not able to figure this out and trying for many days.
Do you use a seperate docker for frigate and docker for HASSOS? Or you have HASSOS and frigate integration?

Not last baby :smiley:

But its like 85bucks i dont know if its normal price :-E

1 Like


I took for 80€ include shipping from germany to italy. I know pci cost less but my slot was already occupied.

1 Like

is the coral worth it?


question, when i configure 2 RTSP streams

width: 2304
height: 1536

width: 1280
height: 720

how i should configure the setting? can be possible to set a different resolution for each stream?


1 Like

Okay can please somebody help, in const.py can i put remote share and how to be mounted?
Thank you

I finaly able to get inside the container and i am not able to mount remote share.
Any advises?
Thank you <3

root@ccab4aaf-frigate:/opt/frigate/frigate# mount -t nfs /media/frigatemount.nfs: access denied by server while mounting
root@ccab4aaf-frigate:/opt/frigate/frigate# mount -t cifs -o username=asdf,password=asdf,domain=WORKGROUP,vers=2 // /media/frigate
mount: /media/frigate: cannot mount // read-only.
root@ccab4aaf-frigate:/opt/frigate/frigate# mount -t cifs -o username=asdf,password=asdf,domain=WORKGROUP,vers=3  // /media/frigate
mount: /media/frigate: cannot mount // read-only.
root@ccab4aaf-frigate:/opt/frigate/frigate# mount -t cifs -o username=asdf,password=asdf,domain=WORKGROUP,vers=1  // /media/frigate
mount: /media/frigate: cannot mount // read-only.

I did even make the share accesible for anyone

I didn’t tested a lot at the moment. I’m still trying to setup masks, detect etc. I wll use it to just 3 cams on my balconies so I don’t think it will produce a lot of work. It would be GREAT if Face Detection and Recognition will be added. At the moment I’m studing this soluton

This could bring room detection to another level !

1 Like

I’m running Supervised on an Ubuntu box and just mount an external USB 3.0 drive to /usr/share/hassio/media in fstab on the host box.

Presumably you could do the same/similar via a network share.

yeah i am trying, thx for reply. I can’t mount smb neither nfs. each giving errors. still working on that. As this might be a perfect solution

You seem to be trying it from within the container, whereas I’m doing it from the host box itself - with the Supervised install anyway, it maps /usr/share/hassio/media from the host, to the containers.

thank you for hints, no file or directory hassio in usr share :confused: on HASSOS.
So the files are on the HASSOS or in the container? How does the docker link/mount work on run
I am not able to edit the host options from the HASSOS and i cant see in portainer

I’m afraid I have not used HASSOS, only the (unsupported) supervised install.

But on the host os, if you run:

docker ps

Then get the container ID, so my frigate container ID is 267644069eef

docker inspect -f '{{ .Mounts }}' 267644069eef

It shows me the media mount point:

[{bind /usr/share/hassio/homeassistant /config rw true rprivate} {bind /usr/share/hassio/media /media rw true rprivate} {bind /dev /dev ro false rprivate} {bind /usr/share/hassio/addons/data/ccab4aaf_frigate /data rw true rprivate}]

Which on my setup is /usr/share/hassio/media on the host, which I just remounted to a USB drive instead.