Local Speaker as Media Player

Am I missing something here? I have a regular desktop speaker plugged into the Intel NUC (via 3.5mm jack) what will it take to use this as a Media Player in Home Assistant? I have the VLC Telnet addon installed, but there’s no indication that the speaker is recognized. Also tried with a USB speaker, same results. In the addon configuration, the Input/Output are both set to Default, but no audio. Thoughts?

Is it installed on the NUC on a VM like proxmox? If so make sure you’ve passed through the USB device to your HA VM. If you have or don’t need to, what fixed my similiar issue is going to Settings → System → Hardware → 3 dots top right → Reboot (Not restart).

Then my USB speaker appeared.

I have HA installed directly on the NUC (No VM) and have rebooted, no joy. How can I tell if the speaker is detected? Should I see something in the logs?

Unfortunately I’m not familiar with your HA install, as I run proxmox and spun up my HA install on tha so I could use more more of the computing power for other things. You can, in HA go to the Harwahere section i mention → 3 dots → and click All Hardware. This will then list your hardware including your USB if recognised. You’ll need to know what you’re doing. It may be worth searching up on USB device install for the specific method you used to setup your HA instance.

Success. Seems like a reboot of the NUC may have fixed it. I now see the USB speaker as the following…

One question, how am I able to control the volume? TTS seems to be pretty loud.

Hello, I have stumbled upon this thread trying to get a USB speaker to work. I have HA running on a mini PC via Proxmox.

I have successfully tested the USB speaker directly in proxmox so I know it can send sound to the hardware, before setting usb device pass through.

I can see the USB audio device in the hardware list and ha audio info lists it, and I can select USB AUDIO Analog Stereo as an output in the VLC add-on. But there’s no sound coming out when playing a file through VLC.

ha audio logs contains the following:

W: [pulseaudio] main.c: Running in system mode, but --disallow-module-loading not set.
W: [pulseaudio] main.c: Home directory of user 'root' is not '/var/run/pulse', ignoring.
W: [pulseaudio] caps.c: Normally all extra capabilities would be dropped now, but that's impossible because PulseAudio was built without capabilities support.
W: [pulseaudio] main.c: OK, so you are running PA in system mode. Please make sure that you actually do want to do that.
W: [pulseaudio] main.c: Please read http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/ for an explanation why system mode is usually a bad idea.
W: [pulseaudio] module-udev-detect.c: Failed to open /proc/asound/card1: No such file or directory
N: [pulseaudio] alsa-util.c: Disabling timer-based scheduling because running inside a VM.
E: [pulseaudio] module-rescue-streams.c: module-rescue-stream is obsolete and should no longer be loaded. Please remove it from your configuration.
N: [pulseaudio] alsa-util.c: Disabling timer-based scheduling because running inside a VM.
E: [alsa-sink-USB Audio] alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write.
E: [alsa-sink-USB Audio] alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_usb_audio'. Please report this issue to the ALSA developers.
E: [alsa-sink-USB Audio] alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
N: [pulseaudio] alsa-util.c: Disabling timer-based scheduling because running inside a VM.

Wondering if anyone has any ideas for further debug/testing I can try?