Local Tuya - Cannot Connect to Device

I have several Tuya RGB lights. I have 7 of the 16 added to HA but am now having trouble adding them. I keep getting the error "Cannot connect to device. Verify that address is correct and try again". I have tried several lights, and confirmed that I have the correct IP address, ID, and Key. I confirmed that the light is connected to my network, I can control the light with my phone Tuya app and I can see it connected in my unifi dashboard. I also tried reloading the integration and restart HA. The Local Tuya integration errors out pretty much instantly. Within 0.5 seconds of hitting submit. I don’t see any issues in my logs.

I’m using local tuya 4.0.

Any idea how to fix this?

Just adding more info.

I set my logger to debug

  default: warning
    custom_components.localtuya: debug

I made sure my API connection was good.
2022-06-18 10:47:28 INFO (MainThread) [custom_components.localtuya] Cloud API connection succeeded.

I did a reset on the light. Still getting the same error

Nothing is showing up in the logs. I have 7 other lights connected, they are all offline because I haven’t wired them yet (I just temporarily wired them to add them to HA). So my log is showing that the connection to those lights has failed. I’m not sure if those lights fialing to connect are causing the issue?

I figured this out. I ended up having an IP address conflict with both of the lights I was troubleshooting with. My Unifi system gave them IPs that were the same as two of my security cameras. Which is odd since the cameras are hardwired and always connected. But, that was my issue.

Just an FYI on something to check if you have a similar issue.

1 Like