Local Tuya cant find my devices correctly

Tags: #<Tag:0x00007fc4189fc8b8>

Local Tuya finds other device IDs than the ones reported by the app or the Tuya API and I also always get the same local key for all my devices, can someone help me ?

Please elaborate and add screenshots.


These are my Devices with ID´s and HA is not detecting them correctly

Screenshot 2021-04-23 100938

What do you mean

And I don’t understand

Where are you getting the local keys?

I am getting them from the https://iot.tuya.com/ website like it is described in all the guides and youtube videos, I get a response from the API but its always the same local key for all my different devices.

HomeAssistant can auto discover the devices on my home network right ? like it does for everyone else apparently and for me it discovers devices too but they have different IDS so idk why it is doing that and how to fix it.

How?

I have a feeling that you’re misinterpreting this.

Did you expect all of the devices to have the same ID?

I don’t think it’s a problem. Screenshot of this “incorrect” behavior?

If you compare the device IDs in the pictures I posted I have 3 devices as shown in the screenshot from tuya but the one with the dropdown menu is from HA from LocalTuya and it shows different IDs, and no the devices have all unique ids and should have unique local keys too.

I am getting my keys from the API on the developer account on tuya.

In all of the tutorials I’ve seen, none of them say to go to the Tuya Cloud’s registered devices to find the IDs and keys. Did you try looking at

yet?

Yes I tried that method too, gave me the same local key for everything again.
image

And you get an error when you configure it with those IDs and keys, right? What is it?

Yes I get an error even though its the Device ID and local key from the CLI interface (which is the same as when I get the local keys through the Tuya Website)


this is the error.

You also need to use the right host.

I am the 192.168.10.62 is my zigbee gateway’s Ip

Why are you using the id for the temperature and humidity sensor with the zigbee hub’s IP?

Cause it doesnt have its owns since its zigbee, and I also tried using my homeassistant IP as the host IP but that still doesn’t work

You should try raising an issue at localtuya. Also, what happens if you directly set up the zigbee gateway instead of another device?

I tried that too but it doesnt work either. I think ill have to do that yeah.