Local Tuya Integration Setup fails with Failed to retrieve device list. Error 1106: permission deny

I had previously set up the Local Tuya integration on my HA instance, but the SD card got damaged so now I am having to try to recreate it. When I try to add the integration again, I enter my Client ID, Secret, Tuya Portal UserID, and Tuya Portal password, but get the message “Failed to retrieve device list. Error 1106: permission deny”. Region is correctly set to US data center in the local integration settings. I also tried adding my external IP to the allowed list on the Tuya portal but still receive this message. The Device ID shows online on the Devices tab of my Tuya portal project. In short, nothing has changed on the Tuya portal side unless the portal itself changed.

The reason I am using the local vs. official Tuya integration is that the local version supports some features of the Tuya wifi presence sensor ZY-M100 that are not supported by the official one, like illuminance.

Any suggestions are welcome.

is your tuya developer account still active? If you use the auto provisioning of localtuya, you need an active dev account for the setup. you don’t need it ongoingly nor if you do manual config.

if it is no longer active you can apply for a 6 mo extension and it’s pretty automatic in about 24 hrs

If you mean by actuve developer account that I still have an active project under Development/My Cloud Projects and can log in to the IoT developer account, so I think so.

It was pilot error. The userID I should have been using is the one called UID shown on the Tuya portal under Cloud/Devices tab/Link Tuya App Account tab.

With all that said, the integration gets linked successfully but I still have to manually add in all the individual entities for the device. I don’t remember having to do this in the past.

yes, you have to add them manually. Using the cloud account it will identify them for you, pull the local key, the IP address and such, but you still need to name them.

Thanks. The values for near and far detection are two decimal places but HA shows them as units, i.e., 6,30 appears as 630 and .60 appears as 60. The Scaling Factor only allows .1, so it seems the only way to get the value to be accurate is to use .1 as the scaling factor and then use a template to divide by 10, or just skip the scaling factor and use a template to divide by 100?

I’m unfamiliar with what device you are referring to. perhaps it’s reporting out different units (cm vs m?) than you want… but accurate for the units it’s reporting in.

if that might be the case, create the entity then go to the entities page, open up the properties on it and see if you can change the units.

Yes it’s reporting cm. What confused me was the Tuya app shows it in meters and I’m a typcial American who just barely knows metric.

well, home asssitant can maybe do some converting to feet/yards/smoots/whatever for you…

THANK YOU! That solved my problem.

How does one apply for an extension?