Local Tuya Lights Issue

Hi everyone!
I have correctly configured Local Tuya with Home Assistant and followed the whole process on the loT site, obtaining the various local keys. However, I have a problem with the configuration of the lights. In fact, when I go to insert the values, referring to the following page (tinytuya · PyPI), although I have devices with version 3.3, the values that the integration allows me to insert range from 0 to 10 and not from 20 to 30, as it should be. Do you know how can fix it?
Thank you!!


I have been struggling with this for a few days now too. I have tied every configuration of that page to get the light to work, and the only thing I can get right is ON/OFF.

Have you found a solution?

Yes I fixed It!
I realized that everything is well explained on the official release.
Each value to be entered is there!

id: 4 # Usually 1 or 20
color_mode: 21 # Optional, usually 2 or 21, default: “none”
brightness: 22 # Optional, usually 3 or 22, default: “none”
color_temp: 23 # Optional, usually 4 or 23, default: “none”
color: 24 # Optional, usually 5 (RGB_HSV) or 24 (HSV), default: “none”
brightness_lower: 29 # Optional, usually 0 or 29, default: 29
brightness_upper: 1000 # Optional, usually 255 or 1000, default: 1000
color_temp_min_kelvin: 2700 # Optional, default: 2700
color_temp_max_kelvin: 6500 # Optional, default: 6500
scene: 25 # Optional, usually 6 (RGB_HSV) or 25 (HSV), default: “none”
music_mode: False # Optional, some use internal mic, others, phone mic. Only internal mic is supported, default: “False”


Oh my gosh. It was there the whole time! thank you. I read that thing a few times.
I think it was:
color: 24 # Optional, usually 5 (RGB_HSV) or 24 (HSV), default: “none”, that messed me up.
I set colour to value 5 and it worked!

Thanks for helping a noob.


I have been struggling with this for weeks, and have been rooting around on this forum trying to find an answer.

Would you be able to give a bit more detail on how you solved this? Where is the information that you found to guide you?

These are the options that I have currently.

I also only have 0-10 options in the drop-downs on the entity config - Editing entity with DPS 1 and platform light .

So, I updated localtuya and after a number of tries deleting and re-adding the bulb using a number of different values in each of the configuration options I now have full control, full colour.

The only way (that I found) to get back to the full options list is to delete the integration and add it again.

Sometimes it is possible to change a few settings to try things, sometimes this results in the bulb becoming unavailable - in which case delete and start again.

Very frustrating, but got there in the end.

Cant thank you enough. Been at this for hours trying to figure this out. After a couple times the trial period ended on the tuya platform. I had enough of it and decided to switch to local. Thanks again for your information

Im lost configuring a wake up light in local tuya, the device has brightness control in 20 steps, I can’t get the brightness slider to work, can anyone help?

Thank you, thank you. This fixed the issue perfectly where I was unable to access the scenes/lighting effects.

For note, after completing install of my smart bulbs on Local Tuya (the one by rospogrigio) I entered in the information you had specified in the drop-down fields and restarted HA. After it came back up, the devices were again available and the effects able to be edited. Thank you again for sharing this fix as I couldn’t find it elsewhere.

Hi everyone,

Thanks for all the feedback that I got to set up my configuration correctly on the normal RGB lights.
After knowing this I played around a bit on the Tuya “Globe Fairy Lights” and the “Fairy Lights” which as far as i can see now, need to be set up the same but slightly differ from the normal RGB light bulbs.
So for anyone that is interested or have found another way, I´m sharing my set up here.
Not tested it in full but it appears to be working for now, like this.

I was fiddling with this for a long time. I found an API that displays human readable descriptions for the properties instead of IDs. It would be great if localtuya could display those values instead of the IDs.

In your tuya developer account, go to “API Explorer” → “Device Control” → “Query Properties”. Enter the device id. You will get “code” names for the properties, e.g. dp_id 22 has the code name “bright_value” which makes much more sense to me than just the number “22”.

You could try Tuya Local - different integration, not as DIY (your device may not be supported, but if it is it’s as simple as selecting its type).