Local "Virtual" Media player entity

Hello. I’m about to migrate to home assistant but i have a real issue here. right know i have an rasperry pi with 3.5mm audio out connected to an amplyfier that wire all the ceilling speakers in the house. it’s used for doorbell ,general notifications for all sensord temperatures etc.
Now due raspberry pi 3 limitation and rp4 out of stock i got an NUC like pc(msi) with pentium n6000 and have the same 3.5mm audio out. But like we know many fights with mpd and vnc-telnet end up not working after some updates on HA .
Could be an local audio “Virtual” entity created/implemented ?,that direct sound to audio card instead of audio servers and more complex solutions,for use with tts , automations and local media.
Comon !! year of voice and the system can’t play a direct audio card sound!!! :upside_down_face:

HA is installed on debian 12 supervised like says here: Installing Home Assistant Supervised using Debian 12

the audio output on debian its working good

Good to know. How do you make it work?

can we use named pipes?

its working by default with mesa drivers(default)

on vm virtualbox or vmware didn’t worked

Mesa drivers are graphic drivers :wink:
What application are you using to read and decode the mp3/ogg/wma/whatever?
What sound system is you Debian configured for, that will play the audio samples extracted from those files? Alsa / Pulse audio / Other?

You might think playing audio is easy, but it’s not.

Sorry i was distracted :joy: audio card used HD audio i believe. when i’m home i will make sure.
Any way i tryed again my oracle vm virtualbox and debian install good and this time with sound working on hd intel audio or ac 97 (emulation?), do you need i do some tests here? i should say that i’m electronic engineer (the hardware guy)but i hate programming and linux… so be kind in what you ask :wink:

What application are you using to read and decode the mp3/ogg/wma/whatever?

Any aplication; vlc ,web browser … i don’t have any problem playing audio files or youtube etc on debian . the issue is we can’t have an entity to automate or chose on tts inside home assistant .
On domoticz and raspberry pi that i’m about to retire i created some bash scripts that play thought aplay any wav sound i need but i think home assistant can be more user friendly if have this entity created already for the user chose "local " or play on server sound card. Many time they are intel HD audio drivers with realtek chips now a days,unless its an raspberri 4 .
Sorry i really don’t now whats involved in play an audio file from inside HA ,but if it plays well from HA media player when we chose browser,why don’t have any way of do that from an pre configured entity? like play on vlc or any service running in background

I have no experience with the following but it may meet your requirements:


no it’s not working anymore second some say

Past some time i come back with a solution, to finaly make this working and the solution that worked fr me is VLC TELNET that this time worked.before i was running Debian supervised and that maybe cause this didn’t work before. Now i’m using home assistant core now installed by snap . the system is runing on MSI CUBI N(nuc style) ubunto 22 with kde plasma. (gnome can’t sleep the asus screens on this setup).

MDP i couldn’t make it run because lack of information . i stays installed and run but unavailable from HA

on core is needed install vlc :

sudo snap install vlc.      or   sudo apt install vlc   or     sudo apt-get install vlc

then run telnet

vlc -I telnet --telnet-password=123456 --telnet-port=4212

this just run once and if you need add to autoruns. on Ubuntu there are an autorun feature on start menu. create an .sh file and paste this previews instruction there.

now on Home assistant add the" integration " VLC with the password from above instruction. and voila! available from all automations and media player. this ttl voice it’s marvelous.